Перейти из форума на сайт.


Система IP-видеонаблюдения "Линия". Скачать бесплатную демо-версию для 16 камер. НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Модерирует : ShIvADeSt

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503

Открыть новую тему     Написать ответ в эту тему

ShIvADeSt



Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Тема для программирования 1С!!!
Это продолжение темы, предыдущие части доступны тут


 Программы » 1С:Предприятие 1C - 1C: Вопросы по конфигурациям

 Варезник » 1C:Предприятие 7.7 - 1С:Предприятие v.8.x - 1C Диск ИТС - 1С: Совместимо 8.х
Топик 1C Ebooks
ЗДЕСЬ  (обновлено 22.02.14) - небольшая библиотечка (книги, документация, видео, утилиты) по 1С, финансам, бухучету и т.п.
Все рассортировано по версиям...
Для заблудившихся в трех соснах >>> FAQ по форуму RU.Board
 
Предыдущие темы были здесь часть 5 | часть 4 | часть 3 | часть 2 | часть 1
 
Как убить рекламу при обновлении отчетности | конфигурации (ИБ)?

Всего записей: 3916 | Зарегистр. 29-07-2003 | Отправлено: 09:50 30-10-2009 | Исправлено: Akam1, 03:18 06-03-2017
NickBoard

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
GenyaMS
Делаем на форме Элемент поле выбора и называем его ВашСписок.
Потом заполняем его всеми справочниками:

Код:
 
Процедура ЗаполнитьТипамиСправочников()
    сп=Новый СписокЗначений;
    Для Сч=0 По Метаданные.Справочники.Количество()-1 Цикл
        Имя=Метаданные.Справочники[Сч].ПолноеИмя();
        Представление=СтрЗаменить(Имя,"Справочник.","");
        Имя=СтрЗаменить(Имя,".","Ссылка.");
        сп.Добавить(Тип(Имя),Представление);
    КонецЦикла;
    ЭлементыФормы.ВашСписок.СписокВыбора=сп;
КонецПроцедуры
 

Да, не забыть повесить обработчик на ВашСписок:

Код:
 
Процедура ВашСписокПриИзменении(Элемент)
    ВыбТипСправочника=Элемент.Значение;
КонецПроцедуры
 

ВыбТипСправочника может быть как реквизитом, так и обычной переменной. Смотреть по необходимости

Всего записей: 20 | Зарегистр. 11-08-2009 | Отправлено: 10:28 30-10-2009
Skilet



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Для версии 1с8.1
Кто-нить подскажет как лутше всего реализовать в справочнике Периодический реквезит?

Всего записей: 97 | Зарегистр. 12-10-2005 | Отправлено: 11:37 30-10-2009
fol



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Skilet Для хранения периодических данных используй периодический регистр сведений.

Всего записей: 805 | Зарегистр. 02-11-2002 | Отправлено: 12:10 30-10-2009
An4eus



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
niko7
Цитата:
niko7
Цитата:
Набил я сегодня на несколько символов больше поля ввода, хочу вбить еще и не удается. Почему не удается не понимаю, как отследить? Ещё раз посмотрел, стоит строка неограниченной длинны.
перенос сделай в поле

Цитата:
An4eus
Цитата:
перенос сделай в поле
Как сделать, не понимаю.
в конфигураторе правой кнопкой на многострочный реквизит  -> Тип -> галка Многострочный

----------
Век живи - век учись!

Всего записей: 3768 | Зарегистр. 23-07-2007 | Отправлено: 13:15 30-10-2009
NickBoard

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Skilet
Для начала почитать литературу. В восьмерке нет периодических реквизитов. Вместо них используются регистры сведений

Всего записей: 20 | Зарегистр. 11-08-2009 | Отправлено: 15:42 30-10-2009
Skilet



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Для начала почитать литературу. В восьмерке нет периодических реквизитов. Вместо них используются регистры сведений


Цитата:
Skilet Для хранения периодических данных используй периодический регистр сведений.

Я все знаю, что нету периодических данных!!!!
 
Я задал вопрос, как лутше всего РЕАЛИЗОВАТЬ, т.е. как лутше всего эти данные добавлять, удалять, изменять и т.п. Через документы или всетаки мучаться в самом справочнике через обработку события ПриИзменение <>

Всего записей: 97 | Зарегистр. 12-10-2005 | Отправлено: 15:52 30-10-2009
NickBoard

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Skilet
Смотря для чего нужен этот реквизит. Цену например, удобнее регистрировать документом, а ответственного изменять удобнее сразу из карточки справочника

Всего записей: 20 | Зарегистр. 11-08-2009 | Отправлено: 16:20 30-10-2009
tran4ik

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Помогите поожалуйста!
Имеется два справочника: Номенклатура и Партии, причем спр. Партии ПОДЧИНЕН справочнику Номенклатура.
 
Выбираю элемент из Номенклатуры (ном.НайтиПоНаименованию(....)). Теперь необходимо программно выбрать один из элементов подчиненного справочника Партии
и, например сообщить один из его реквезитов (Сообщить(Парт.Цена)).
 
Как это реализовать????????
 
Заранее спасибо

Всего записей: 111 | Зарегистр. 14-09-2008 | Отправлено: 16:49 30-10-2009
dias65



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
tran4ik
Все довольно просто:
(Подразумевается 1С7.7)
Код:
Парт = СоздатьОбъект("Справочник.Партии");
Парт.ИспользоватьВладельца(Ном.ТекущийЭлемент());
Если Парт.ВыбратьЭлементы()=1 Тогда
 Парт.ПолучитьЭлемент(); //здесь алгоритм получения нужного элемента
 Сообщить(Парт.ТекущийЭлемент().Цена);
//Для периодического реквизита Сообщить(Парт.ТекущийЭлемент().Цена.Получить(<Дата>));
КонецЕсли;
А вообще вопрос уж слишком...
Лень книжку почитать.
 
ЗЫ Подправил на всякий случай для других.

Всего записей: 277 | Зарегистр. 28-11-2006 | Отправлено: 22:04 30-10-2009 | Исправлено: dias65, 07:49 02-11-2009
tran4ik

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
А вообще вопрос уж слишком...  
Лень книжку почитать.

 
Всю книжку перелопатил. Делал также. Ни фига! Разобрался - Цена была реквизитом-то периодическим! Все-равно спс!!!!!!!

Всего записей: 111 | Зарегистр. 14-09-2008 | Отправлено: 01:12 31-10-2009
GenyaMS



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
NickBoard - Еще раз спасибо! Все работает! Все это и требовалось сделать.Еще  
Процедура ВашСписокПриИзменении(Элемент)  
    ВыбТипСправочника=Элемент.Значение;  
КонецПроцедуры
В переменную ВыбТипСправочника данные записывает,  
а вот если сделаю реквизит на поле формы, например Элемент:Текст (просто так выбрал), то при выводе на форму - пишет Что-то типа Запрещена запись... Я сам посмотрел свойства данного реквезита, но напрямую данного ненашел... Где можно отключить- защиту от записи данных?
 
Добавлено:
Кто с реестром сертификатов на товары сталкивался, когда к накладной требуется вывести еще дополнительную печатную форму, с перечнем сертификатов товаров?  
для 7_7 Управление Бухгалтерией  
   
Как лучше сделать: надо в справочнике Номенклатура - дополнительный реквизит повесить: Сертификат? или отдельный справочник сделать? Если отдельный то каждому товару будет подчинен свой справочник-сертификаты(как справочник дорговорв - справочнику контрагенты)?

Всего записей: 184 | Зарегистр. 24-01-2009 | Отправлено: 11:35 31-10-2009
Fantom 14



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Ситуация такая, упала система а вместе с ней и периферийная база 1с и ее архивы. Удалось реанимировать архив месячной давности. Хочу из центральной базы перегрузить все доки по этой базе за этот месяц. Но тут такая ситуация, в этот период меняли глобальный модуль в центре и изменения прошли по всем базам. Можно ли эти изменения занова как-нибудь загрузить в периферийную?

Всего записей: 322 | Зарегистр. 23-10-2004 | Отправлено: 15:35 31-10-2009
NickBoard

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Fantom 14
Можно. Добавить в синоним БД точку или пробел, а потом обычная выгрузка-загрузка. Но лучше всего будет выгрузить узел заново.

Всего записей: 20 | Зарегистр. 11-08-2009 | Отправлено: 21:41 31-10-2009
Fantom 14



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
в смылсе в синоним? поподробнее можно?

Всего записей: 322 | Зарегистр. 23-10-2004 | Отправлено: 00:26 01-11-2009
NickBoard

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Fantom 14
открыть центральную бд в конфигкраторе,  
меню конфигурация - открыть конфигурацию.  
В появившемся ниже окошке правой нопкой мыши нужно нажать на первой строке, выбрать меню свойства.  Появится окошко с четырьмя закладками, на первой есть три поля ввода, собственно нужен синоним. Надеюсь достаточно подробно)). Предупреждаю, конфигурацию прийдется выгружать на все имеющиеся распределенные узлы, дешевле заново выгрузить один узел, а там как знаете

Всего записей: 20 | Зарегистр. 11-08-2009 | Отправлено: 01:06 01-11-2009
Vunicode



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подскажите пож. как в доке сделать имя пользователя последнего проведения в бух. 7.7  ?

Всего записей: 273 | Зарегистр. 02-09-2007 | Отправлено: 19:08 01-11-2009
poozpooz



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Как сделать в "счете на оплату покупателю" (конф бух 8) итоговую сумму по услугам и по товарам отдельно по каждой вкладке?

Всего записей: 6 | Зарегистр. 18-02-2009 | Отправлено: 01:06 02-11-2009
polubotinok



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
poozpooz
свойство колонки "Отображать итоги подвала"

Всего записей: 20 | Зарегистр. 21-10-2008 | Отправлено: 05:34 02-11-2009
poozpooz



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
polubotinok

 
расчет я имею в виду, а отображаться в подвале или не в подвале эта сумма будет мне все равно
 
Процедура РасчетСуммы()
СуммаДокумента = 0;
Для Каждого СтрокаТовары Из Товары Цикл  
    СуммаДокумента = СуммаДокумента + СтрокаТовары.Сумма;    
КонецЦикла;    
ЭлементыФормы.СуммаПоТоварам.Значение = СуммаДокумента;
КонецПроцедуры    
 
Что -то на подобие, только наверно не так просто?
 
    

Всего записей: 6 | Зарегистр. 18-02-2009 | Отправлено: 16:37 02-11-2009
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503

Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru