#
Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Модерирует : ShIvADeSt

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551

Открыть новую тему     Написать ответ в эту тему

ShIvADeSt



Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Тема для программирования 1С!!!
Это продолжение темы, предыдущие части доступны тут


 Программы » 1С:Предприятие 1C - 1C: Вопросы по конфигурациям

 Варезник » 1C:Предприятие 7.7 - 1С:Предприятие v.8.x - 1C Диск ИТС - 1С: Совместимо 8.х
Топик 1C Ebooks
ЗДЕСЬ  (обновлено 22.02.14) - небольшая библиотечка (книги, документация, видео, утилиты) по 1С, финансам, бухучету и т.п.
Все рассортировано по версиям...
Для заблудившихся в трех соснах >>> FAQ по форуму RU.Board
 
Предыдущие темы были здесь часть 5 | часть 4 | часть 3 | часть 2 | часть 1
 
Как убить рекламу при обновлении отчетности | конфигурации (ИБ)?

Всего записей: 3951 | Зарегистр. 29-07-2003 | Отправлено: 09:50 30-10-2009 | Исправлено: M_Volkov, 11:12 14-01-2020
1nasty1



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Помогите пожалуйста, с таким вопросом:
 
Есть обработка:
 

Код:
Процедура Заполнить(ДокументОбъект,ТабЧасть) Экспорт  
    Перем Файл;
    Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    Диалог.Заголовок = "Выберите файл";
    Диалог.ПолноеИмяФайла = "";  
    Фильтр = "TXT (*.TXT)|*.TXT";  
    Диалог.Фильтр = Фильтр;  
    Диалог.МножественныйВыбор = Ложь;
    Если Диалог.Выбрать() Тогда
        Файл = Диалог.ПолноеИмяФайла;
    КонецЕсли;
    
    Счетчик = 1;  
    мЧтение = Новый Массив;  
    рМассив = Новый Массив;  
    
    
    Текст = Новый ТекстовыйДокумент;
    Попытка
        Текст.Прочитать(Файл,"iso-8859-5", Символы.ПС);
    Исключение
        Сообщить(ОписаниеОшибки());
    КонецПопытки;
    
    Для Номер = 1 По Текст.КоличествоСтрок() Цикл     
        Если Номер = 1 Тогда
            Продолжить;
        КонецЕсли;    
        Стр = Текст.ПолучитьСтроку(Номер);
        
        мЧтение.Добавить(Стр);  
        Если СокрЛП(Стр) = "03" ИЛИ СокрЛП(Стр) = "#joborder complete#" Тогда
            Если мЧтение.Количество()>1 Тогда
                Результат = ПарсингРезультата(мЧтение,Счетчик);  
                Если Результат.Количество() > 0 Тогда
                    рМассив.Добавить(Результат);    
                КонецЕсли;
                Счетчик = Счетчик + 1;  
                мЧтение.Очистить();
            Иначе  
                мЧтение.Очистить();
            КонецЕсли;
        КонецЕсли;
        
        Для Каждого СтрокаТЧ Из рМассив Цикл  
            //Сообщить(""+СтрокаТЧ.Работа+"  "+СтрокаТЧ.НЧ+"");
            
            ТекНоменклатура = Справочники.Автоработы.НайтиПоНаименованию(СокрЛП(СтрокаТЧ.Работа));  
            Если ТекНоменклатура <> Справочники.Автоработы.ПустаяСсылка() Тогда
                
                Нов = ДокументОбъект.Работы.Добавить();
                Нов.Работа = ТекНоменклатура;
                Нов.Количество = 1;
                Нов.Коэффициент = 1;
                ДокументОбъект.ОбработкаРеквизита("Работы.Работа",Нов,);
                
            Иначе
                Сообщить("НЕ найдена работа: "+СтрокаТЧ.Работа+" "+СтрокаТЧ.НЧ+" строка НЕ добавлена");
            КонецЕсли;
            
            
        КонецЦикла;
        
 
        
    КонецЦикла;
    
 
КонецПроцедуры
 
Функция ПарсингРезультата(Массив,Счетчик)
    рСтруктура = Новый Структура;  
    // Это работа  
    Если Счетчик <> 1  Тогда
        Попытка рСтруктура.Вставить("Номер",Массив[0]+"-"+Массив[1]+"-"+Массив[2]); Исключение КонецПопытки;
        Попытка рСтруктура.Вставить("НЧ",Число(Массив[3])/10); Исключение рСтруктура.Вставить("НЧ",0);  КонецПопытки;
        
        // Получаем работу
        НомерСтроки = 6;
        Работа = "";  
        Пока НомерСтроки < Массив.Количество() Цикл
            Стр = СокрЛП(Массив[НомерСтроки]);  
            Если Стр <> "03" И Стр <> "#joborder complete#" Тогда  
                Работа = Работа + Стр+" ";  
            КонецЕсли;
            НомерСтроки = НомерСтроки + 1;  
        КонецЦикла;
        Попытка рСтруктура.Вставить("Работа",Работа); Исключение КонецПопытки;        
    КонецЕсли;
    
    Возврат рСтруктура;  
    
КонецФункции
 

 
Вот так визуально выглядят данные, которые должна загрузить обработка:
 
   
 
Эти же данные, но уже в готовом к загрузке текстовом формате:
 

Код:
VERSION=1
01
00
26.01.2020
01:03
WDB2110161A031891
00
22
10
   
28 211 E-класс
13 E 270 CDI
E 270 CDI
647961
 
 
03
03
3000
06
015
0
R
Передний сальник коленчатого вала (со                                                                                                                  
стороны ременного привода): заменить                                                                                                                  
                                                                                                                                                       
                                                                                                                                                       
03
03
1284
02
003
0
R
Ременный шкив коленчатого вала с демпфером снять,                                                                                                      
установить, по результатам осмотра заменить (двигатель снят)                                                                                          
                                                                                                                                                       
                                                                                                                                                       
03
03
3013
01
002
0
R
Передний сальник коленчатого вала (со стороны                                                                                                          
ременного привода): заменить (доступ обеспечен)                                                                                                        
                                                                                                                                                       
                                                                                                                                                       
03
03
6111
01
 ZM
0
R
Шатуны (все): измерить                                                                                                                                
соосность отверстий (шатун снят)                                                                                                                      
                                                                                                                                                       
                                                                                                                                                       
03
03
7061
04
023
0
R
Поршни (все): снять и установить                                                                                                                      
(двигатель и головка цилиндров сняты)                                                                                                                  
                                                                                                                                                       
                                                                                                                                                       
03
14
1310
04
027
0
R
Впускной коллектор                                                                                                                                    
снять, установить                                                                                                                                      
                                                                                                                                                       
                                                                                                                                                       
#joborder complete#

 
и есть результат загрузки:
 

Код:
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: стороны ременного привода): заменить    0 строка НЕ добавлена
НЕ найдена работа: установить, по результатам осмотра заменить (двигатель снят)    0 строка НЕ добавлена
НЕ найдена работа: ременного привода): заменить (доступ обеспечен)    0 строка НЕ добавлена
НЕ найдена работа: соосность отверстий (шатун снят)    0 строка НЕ добавлена
НЕ найдена работа: (двигатель и головка цилиндров сняты)    0 строка НЕ добавлена
НЕ найдена работа: Впускной коллектор снять, установить    2,7 строка НЕ добавлена

Я так понимаю, что обработка не может справиться с форматированием строк и пытается загрузить целое частями. как исправить эту проблему?
 
 

Всего записей: 686 | Зарегистр. 11-03-2005 | Отправлено: 01:19 26-01-2020 | Исправлено: 1nasty1, 01:28 26-01-2020
iRiverStone

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
1nasty1
Если есть возможность изменить выгрузку - просто попросите не переносить строки с описанием работ и всё должно заработать.

Всего записей: 1077 | Зарегистр. 29-03-2016 | Отправлено: 06:05 26-01-2020
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
1nasty1

Код:
            ТекНоменклатура = Справочники.Автоработы.НайтиПоНаименованию(СокрЛП(СтрокаТЧ.Работа));  
            Если ТекНоменклатура <> Справочники.Автоработы.ПустаяСсылка() Тогда  
                 
                Нов = ДокументОбъект.Работы.Добавить();  
                Нов.Работа = ТекНоменклатура;  
                Нов.Количество = 1;  
                Нов.Коэффициент = 1;  
                ДокументОбъект.ОбработкаРеквизита("Работы.Работа",Нов,);  
                 
            Иначе  
                Сообщить("НЕ найдена работа: "+СтрокаТЧ.Работа+" "+СтрокаТЧ.НЧ+" строка НЕ добавлена");  
            КонецЕсли;
Может в твой базе действительно нет этих работ?

Всего записей: 4689 | Зарегистр. 23-06-2008 | Отправлено: 08:47 26-01-2020
1nasty1



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору

Цитата:
Если есть возможность изменить выгрузку - просто попросите не переносить строки с описанием работ и всё должно заработать.

Я посмотрю, но, думаю, нет возможности штатно это сделать

Цитата:
Может в твой базе действительно нет этих работ?

Обработка пытается не полностью загрузить работу, а "кусками". Посмотрите, что она пытается создать. Конечно, какой работы нет, а вот полное название в списке авторабот присутствует.
----
а вот эта обработка загружает в бухгалтерию нормально, правда, файл нужно сохранять не в txt, а в utf :
 

Код:
Процедура КоманднаяПанельПродукцияЗагрузитьУслуги(Кнопка)
    
    ДиалогФыбораФайла = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
    
    ДиалогФыбораФайла.Фильтр                      = "Текстовый файл (*.utf)|*.utf";    
    ДиалогФыбораФайла.Заголовок                   = "Выберите файл для выгрузки данных из клиента банка";
    ДиалогФыбораФайла.ПредварительныйПросмотр     = Ложь;
    ДиалогФыбораФайла.Расширение                  = "utf";
    ДиалогФыбораФайла.ИндексФильтра               = 0;    
    ДиалогФыбораФайла.ПроверятьСуществованиеФайла = Ложь;
    
    Если ДиалогФыбораФайла.Выбрать() Тогда
        ФайлЗагрузки = ДиалогФыбораФайла.ПолноеИмяФайла;
    КонецЕсли;
    
    Импорт_ТекстДляРазбора = ПрочитатьФайл(ФайлЗагрузки);
    
    Если Импорт_ТекстДляРазбора = Неопределено Тогда
        Предупреждение("Файл загрузки не содержит данных!");
        Возврат;
    КонецЕсли;
    
    Импорт_КоличествоСтрок = СтрЧислоСтрок(Импорт_ТекстДляРазбора);
    Импорт_ТекущаяСтрока = 1;
    
    Флаг = Ложь;
    //ФлагВремя = 1;
    ФлагВремени = Ложь;
    ВремяВыполненияОперации = 0;
    
    Пока Импорт_ТекущаяСтрока <= Импорт_КоличествоСтрок Цикл
        
        Если ФлагВремени Тогда
            ФлагВремя = ФлагВремя + 1;
        КонецЕсли;    
        
        Стр = ПолучитьСтрокуИмпорта(Импорт_ТекстДляРазбора,Импорт_ТекущаяСтрока,Импорт_КоличествоСтрок);
        
        Если Стр = "R" Тогда
            
            НазваниеУслуги = "";
            Флаг = Истина;
            Продолжить;        
        КонецЕсли;  
        
        Если ФлагВремя = 5 Тогда
            Попытка
                ВремяВыполненияОперации = Число(Стр) / 10;                    
            Исключение
                ВремяВыполненияОперации = 0;
            КонецПопытки;
        КонецЕсли;
        
        Если Стр = "03" Тогда
            
            ДобавлениеУслугиТаблицаУслуг(НазваниеУслуги,ВремяВыполненияОперации);
            Если НазваниеУслуги <> "" Тогда
                
                ФлагВремя = 1;
                ФлагВремени = Истина;    
                Флаг = Ложь;            
                НазваниеУслуги = "";                
            КонецЕсли;                
        КонецЕсли;
        
        Если Найти(Стр,"#") > 0 Тогда
            ДобавлениеУслугиТаблицаУслуг(НазваниеУслуги,ВремяВыполненияОперации);
            Прервать;
        КонецЕсли;
        
        Если Флаг Тогда
        
            НазваниеУслуги = НазваниеУслуги + Стр;
        
        КонецЕсли;  
    КонецЦикла;    
    
КонецПроцедуры

 
может их можно как-то "скрестить"?

Всего записей: 686 | Зарегистр. 11-03-2005 | Отправлено: 16:58 26-01-2020 | Исправлено: 1nasty1, 17:09 26-01-2020
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551

Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru

Рейтинг.ru