Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Модерирует : ShIvADeSt

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516

Открыть новую тему     Написать ответ в эту тему

ShIvADeSt



Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Тема для программирования 1С!!!
Это продолжение темы, предыдущие части доступны тут


 Программы » 1С:Предприятие 1C - 1C: Вопросы по конфигурациям

 Варезник » 1C:Предприятие 7.7 - 1С:Предприятие v.8.x - 1C Диск ИТС - 1С: Совместимо 8.х
Топик 1C Ebooks
ЗДЕСЬ  (обновлено 22.02.14) - небольшая библиотечка (книги, документация, видео, утилиты) по 1С, финансам, бухучету и т.п.
Все рассортировано по версиям...
Для заблудившихся в трех соснах >>> FAQ по форуму RU.Board
 
Предыдущие темы были здесь часть 5 | часть 4 | часть 3 | часть 2 | часть 1
 
Как убить рекламу при обновлении отчетности | конфигурации (ИБ)?

Всего записей: 3931 | Зарегистр. 29-07-2003 | Отправлено: 09:50 30-10-2009 | Исправлено: Akam1, 03:18 06-03-2017
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Kreil

Цитата:
Теперь мне очень интересно почему COMconnector не работает, а Application работает...

Дал же ссылку: Обмен данными между базами 1С через COM соединение

Всего записей: 4241 | Зарегистр. 23-06-2008 | Отправлено: 16:20 11-09-2018
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Попросили перенести данные из 7.7 в 8.3 конфигурация МФО. Начал с контрагентов и физ. лиц. В Демо-базе при открытии контрагента, если его вид физическое лицо, то открывается форма физ. лица. А в моей такого не происходит!? Видно что-то не перенес. Что?
В справочнике Физические лица есть ссылка на Контрагенты. А в Контрагенты - нет. В самой форме списка Контрагенты не видно, есть только
Код:
&НаКлиенте
Процедура СписокПередНачаломИзменения(Элемент, Отказ)
    
    Если НЕ Элемент.ТекущиеДанные.ЭтоГруппа Тогда
        КлючеваяОперация = "ОткрытиеФормыКонтрагенты";
        ОценкаПроизводительностиКлиент.НачатьЗамерВремени(Истина, КлючеваяОперация);
    КонецЕсли;
    
КонецПроцедуры

Как определить что не хватает?

Всего записей: 4241 | Зарегистр. 23-06-2008 | Отправлено: 09:45 12-09-2018
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору

Цитата:
Как определить что не хватает?

В смысле посмотреть в демо-базе, по какому признаку принимается решение что открывать форму контрагента или физ. лица? Вроде можно в стеке вызовов? Но не умею им пользоваться... подскажите, как?

Всего записей: 4241 | Зарегистр. 23-06-2008 | Отправлено: 16:06 12-09-2018 | Исправлено: M_Volkov, 16:07 12-09-2018
dmitronn



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
по какому признаку принимается решение что открывать форму контрагента или физ. лица?  

может посмотри в той где работает - поменяй физ на юр или наоборот и посмотри отладчиком по каким признакам переопределяется открытие формы ...

Всего записей: 230 | Зарегистр. 14-07-2010 | Отправлено: 00:25 13-09-2018
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
dmitronn

Цитата:
посмотри отладчиком по каким признакам переопределяется открытие формы ...

Куда, в какую форму, процедуру поставить току останова?

Всего записей: 4241 | Зарегистр. 23-06-2008 | Отправлено: 05:14 13-09-2018
dmitronn



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Куда, в какую форму, процедуру поставить току останова?


Цитата:
В Демо-базе при открытии контрагента, если его вид физическое лицо, то открывается форма физ. лица. А в моей такого не происходит!?

Очевидно в демо-базе открываете форму элемента справ Контрагенты и смотрите при разных видах - физ лицо или юр лицо - куда идет обращение. Точку ставьте - ПриОткрытии , При СозданииНаСервере, При ЧтенииНаСервере - где-то там ....

Всего записей: 230 | Зарегистр. 14-07-2010 | Отправлено: 18:20 13-09-2018 | Исправлено: dmitronn, 18:21 13-09-2018
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
dmitronn

Цитата:
Очевидно в демо-базе открываете форму элемента справ Контрагенты и смотрите при разных видах - физ лицо или юр лицо - куда идет обращение.

Вот и пытаюсь найти это место "куда идет обращение". Ставлю точку останова в форме списка Контрагенты в процедуре СписокПередНачаломИзменения(). Из нее открывается форма: либо Контрагенты или ФизическиеЛица. Но в ней нет этого анализа
Код:
&НаКлиенте
Процедура СписокПередНачаломИзменения(Элемент, Отказ)
    
    Если НЕ Элемент.ТекущиеДанные.ЭтоГруппа Тогда
        КлючеваяОперация = "ОткрытиеФормыКонтрагенты";
        ОценкаПроизводительностиКлиент.НачатьЗамерВремени(Истина, КлючеваяОперация);
    КонецЕсли;
    
КонецПроцедуры
Прошагал эту процедуру, и отладка закончилась.

Цитата:
Точку ставьте - ПриОткрытии , При СозданииНаСервере, При ЧтенииНаСервере - где-то там ....  
В форме списка? Она уже открыта! В форме элемента? Уже поздно, место где анализируется: что открывать - пройдено, не захватывается...

Всего записей: 4241 | Зарегистр. 23-06-2008 | Отправлено: 19:13 13-09-2018 | Исправлено: M_Volkov, 19:25 13-09-2018
LaCastet



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
M_Volkov

Цитата:
Ставлю точку останова в форме списка Контрагенты в процедуре СписокПередНачаломИзменения().


Код:
&НаКлиенте  
Процедура СписокПередНачаломИзменения(Элемент, Отказ)  
     
    Если НЕ Элемент.ТекущиеДанные.ЭтоГруппа Тогда  
        КлючеваяОперация = "ОткрытиеФормыКонтрагенты";  
        ОценкаПроизводительностиКлиент.НачатьЗамерВремени(Истина, КлючеваяОперация);  
    КонецЕсли;  
     
КонецПроцедуры

Я здесь вижу только:

Код:
КлючеваяОперация = "ОткрытиеФормыКонтрагенты";  

 
Попробуйте если влепить:

Код:
 
Если Контрагент Тогда
    КлючеваяОперация = "ОткрытиеФормыКонтрагенты";
Иначе
    КлючеваяОперация = "ОткрытиеФормыФизическиеЛица";
КонецЕсли;
 


----------
Пиво — это еще одно доказательство того, что Господь любит нас и хочет, чтоб мы были счастливы!

Всего записей: 2026 | Зарегистр. 27-07-2005 | Отправлено: 19:24 13-09-2018 | Исправлено: LaCastet, 19:26 13-09-2018
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
LaCastet

Цитата:
Попробуйте если влепить:  

В ОценкаПроизводительностиКлиент.НачатьЗамерВремени(Истина, КлючеваяОперация); нет анализа что открывать.

Всего записей: 4241 | Зарегистр. 23-06-2008 | Отправлено: 19:30 13-09-2018
LaCastet



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
M_Volkov

Цитата:
В ОценкаПроизводительностиКлиент.НачатьЗамерВремени(Истина, КлючеваяОперация); нет анализа что открывать.

Это выполняется практически всегда при любых операциях.
Если до этого что-то в фоне было запущено, можно поискать.

----------
Пиво — это еще одно доказательство того, что Господь любит нас и хочет, чтоб мы были счастливы!

Всего записей: 2026 | Зарегистр. 27-07-2005 | Отправлено: 19:33 13-09-2018
iRiverStone

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
M_Volkov
Там, скорее всего, подписки на события надо смотреть. А что за МФО? На руборде эта конфа есть?

Всего записей: 895 | Зарегистр. 29-03-2016 | Отправлено: 19:34 13-09-2018
M_Volkov



Silver Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
iRiverStone
1С 8.3 Управление микрофинансовой организацией и кредитным потребительским кооперативом ПРОФ, редакция 3.0

Цитата:
В справочнике Физические лица есть ссылка на Контрагенты. А в Контрагенты - нет.

Есть оказывается... заполнил обработкой, и все заработало как надо. Но все же, где, как происходит анализ что открывать... так и не нашел!?
 
Добавлено:

Цитата:
Там, скорее всего, подписки на события надо смотреть.

Обычно отладка начинается по точке останова, или "Остановка по ошибке". А вроде есть еще такой режим: когда в программе начинается какое-то действие, запускается какой-то процесс. Например, фоновое задание запускается, или пользователь что-то начал делать... Как включить этот режим?

Всего записей: 4241 | Зарегистр. 23-06-2008 | Отправлено: 20:32 13-09-2018 | Исправлено: M_Volkov, 07:06 14-09-2018
LineykaSBK



Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Конфигурация: Управление торговлей 11.4
Вопрос: Как программно заполнить этапы графиков оплаты по соглашению в заказе клиента? Заказ клиента создаётся из внешней обработки, с помощью функции "ПолучитьФорму("Документы.ЗаказКлиента.Форма")". Так создаётся для интерактивного открытия формы созданного заказа. Сам ДокументОбъект недоступен. Соответственно реквизиты и методы объекта недоступны

Всего записей: 351 | Зарегистр. 29-05-2008 | Отправлено: 14:46 16-09-2018 | Исправлено: LineykaSBK, 14:47 16-09-2018
destiny_child

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Может кто в тему заглянул новенький и сможет помочь вот в этом вопросе:
http://forum.ru-board.com/topic.cgi?forum=33&topic=10715&start=10240#15
там чуть ниже по странице еще есть доп.пояснение к вопросу/задаче....

Всего записей: 947 | Зарегистр. 01-04-2006 | Отправлено: 17:40 19-09-2018
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516

Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru