Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » Microsoft .NET Framework

Модерирует : gyra, Maz

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137

Открыть новую тему     Написать ответ в эту тему

Rodion

Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Microsoft .NET Framework
 
 

Microsoft .NET Framework  - это платформа для создания, развертывания и запуска Web-сервисов и приложений. Она предоставляет высокопроизводительную, основанную на стандартах, многоязыковую среду, которая позволяет интегрировать  существующие приложения с приложениями и сервисами следующего поколения, а также решать задачи развертывания и использования интернет-приложений. .NET Framework состоит из трех основных частей - общеязыковой среды выполнения, иерархического множества унифицированных библиотек классов и компонентной версии ASP, называемой ASP.NET.

Microsoft .NET Framework 1.0 Redistributable Package + SP3 + KB928367 + KB947739 (2k only) + KB953295 (только для XP Media Center / Tablet PC Edition)
 
Версия 1.0 в настоящее время уже практически не используется, поэтому ставить ее рекомендуется только по необходимости, при работе с программами которые требуют именно ее (Visual Studio 2002, Sound Forge некоторых версий и т.п.). Русского LangPack'а для версии 1.0 не существует. Варианты вышеперечисленных обновлений на русском языке (SP3 Rus, KB928367 Rus и KB947739 Rus) предназначены только для русской версии Framework 1.0 SP2, распространявшейся на дисках с дистрибутивом русской Windows XP SP1. На английские версии Framework они не ставятся. Скачать обе (русскую и английскую) версии для XP можно отсюда. Версии 1.0 SP2 и SP3 входят в состав операционных систем Windows XP Media Center / Tablet PC Edition 2002 (SP1) и 2005 (SP2) соответственно. Версия 1.0 SP2 также распространяется на дисках с операционной системой Windows XP SP1 (в виде отдельного дистрибутива).

Microsoft .NET Framework 1.1 Redistributable Package + LangPack + SP1 + KB953297 + KB971108 (2k only)
 
Версия 1.1 не включает в себя версию 1.0, не требует и не заменяет ее при установке. Используется она чаще, однако устанавливать ее рекомендуется также по необходимости, только для тех программ, которые жестко к ней привязаны. Это обусловлено тем, что пакет .NET Framework 2.0 обеспечивает обратную совместимость с предыдущими версиями, и большинство программ, написанных под 1.0 и 1.1 без проблем работают в среде 2.0 (равно как и программы написанные под 1.0 могут запускаться под версией 1.1). Во избежание конфликтов не рекомендуется ставить версии 1.0 и 1.1 одновременно (некоторые записи в реестре у них общие). Версии 1.1 и 1.1 SP1 входят в состав операционных систем Windows Server 2003 и Windows Server 2003 SP1 / R2SP1 / SP2 / R2SP2 соответственно. Версия 1.1 SP1 также распространяется на дисках с операционными системами Windows XP SP2 и SP3 (в виде отдельного дистрибутива).

Microsoft .NET Framework 2.0 Redistributable Package (x64/ia64) + LangPack (x64/ia64) + KB928365 + KB947746 (2k only)
 
Версия 2.0 и все последующие версии Framework не включают в себя предыдущие версии 1.0 и 1.1, не требуют и не заменяют их при установке. Последняя версия, поддерживающая Windows 98/ME (все существующие обновления для этой версии, а также для версий 1.0 SP3 и 1.1 SP1 с этими ОС несовместимы, при проблемах установки сервис паков для версий 1.0 и 1.1 под Windows 98/ME использовать ключ /q). Эта версия входит в состав операционных систем Windows Server 2003 R2SP1 / R2SP2 и Windows Vista.
 
Microsoft .NET Framework 2.0 SP1 Redistributable Package (x64/ia64) + LangPack (x64/ia64) + KB953300 + KB971110 (2k only)
 
Версия 2.0 SP1 включает в себя версию 2.0 и заменяет ее при установке. Входит в состав операционных систем Windows Vista SP1 и Windows Server 2008.
 
Microsoft .NET Framework 2.0 SP2 Redistributable Package (x64/ia64) + LangPack (x64/ia64) + KB958481 + KB971111 (2k only) + KB974417 + KB976569
 
Версия 2.0 SP2 включает в себя версии 2.0 и 2.0 SP1 и заменяет их при установке. Последняя версия, поддерживающая Windows 2000. Для установки этой и предыдущей версий под этой операционной системой может потребоваться установить обновление KB835732 Эта версия входит в состав операционных систем Windows Vista SP2, Windows Server 2008 SP2 / R2 и Windows 7.

Microsoft .NET Framework 3.0 Redistributable Package (x64) + LangPack + KB928365
 
Версия 3.0 включает в себя версию 2.0. Входит в состав операционной системы Windows Vista.
 
Microsoft .NET Framework 3.0 SP1 Redistributable Package (x64) + LangPack (x64) + KB953300
 
Версия 3.0 SP1 не включает в себя версию 2.0 SP1, но требует ее для установки. При установке на чистую систему также могут потребоваться компоненты Microsoft Core XML Services 6.0 aka MSXML 6.0 Parser (KB933579) (x64), XML Paper Specification Shared Components Pack 1.0 (x64) и LangPack (x64) к нему (необязательно), Windows Imaging Component (x64), а также Software Rasterizer for the Microsoft DirectX 9.0 SDK (x64). Более подробно об изготовлении полноценного дистрибутива к версии 3.0 SP1 можно узнать здесь. Эта версия входит в состав операционных систем Windows Vista SP1 и Windows Server 2008.
 
Microsoft .NET Framework 3.0 SP2 x86/x64 + 2.0 SP2 x86/x64 Redistributable Package + KB958481 / KB958483 + KB974417 +
KB976570

 
Версия 3.0 SP2 не включает в себя версию 2.0 SP2, но требует ее для установки. Скачиваемый по ссылке неофициальный дистрибутив включает обе этих версии для x86 и x64 систем. Русский языковой пакет для версии 3.0 SP2 в дистрибутив не входит и отдельно не распространяется. При установке на чистую систему может потребоваться компонент Microsoft Core XML Services 6.0 aka MSXML 6.0 Parser (включен в дистрибутив). Эта версия входит в состав операционных систем Windows Vista SP2, Windows Server 2008 SP2 / R2 и Windows 7.
 

Microsoft .NET Framework 3.5 Redistributable Package + LangPack (x64/ia64) + KB953300
 
Версия 3.5 включает в себя версии 2.0 SP1 и 3.0 SP1. В начале установки делает попытку соединения с интернетом для закачки языкового пакета. Если этот пакет у вас уже имеется, установку следует производить будучи отключенным от сети. После нескольких неудачных попыток подключения установка продолжится с выводом сообщения об ошибке в конце, которое однако не является свидетельством неправильной установки.
 
Microsoft .NET Framework 3.5 SP1 Redistributable Package + LangPack (x64/ia64) + KB958481 / KB958483 / KB958484 + KB963707 + KB974417 + KB976126
 
Версия 3.5 SP1 включает в себя версии 2.0 SP2 и 3.0 SP2. В начале установки делает попытку соединения с интернетом для закачки языкового пакета. Если этот пакет у вас уже имеется, установку следует производить будучи отключенным от сети. После нескольких неудачных попыток подключения установка продолжится в обычном режиме. Эта версия входит в состав операционных систем Windows 7 и Windows Server 2008 R2.
 

Microsoft .NET Framework 4 Full Standalone Installer + Full LangPack (x86 x64)
Microsoft .NET Framework 4 Client Profile Standalone Installer
 
Версия 4 не включает в себя предыдущие версии (1.0, 1.1, 2.0, 3.0, 3.5), не требует их наличия при установке и не заменяет их.
 
Ввиду семимеговой разницы в размерах, о 4 client profile стоит забыть.

 
 
 

Microsoft .NET Framework 4.5 Standalone Redistributable Package + LangPack
Microsoft .NET Framework 4.5.2 Standalone Redistributable Package + LangPack
Версия 4.5 представляет собой выполняемое на месте обновление версии .NET Framework 4, отличающееся высокой степенью совместимости. Версия 4.5 заменяет версию 4.0 и не включает в себя предыдущие версии (1.0, 1.1, 2.0, 3.0, 3.5), входит в состав OS Windows 8. Удаление версии 4.5 также удаляет более ранние версии 4.0. Если нужно вернуться к версии 4.0, то необходимо переустановить версию 4.0 со всеми обновлениями.
Microsoft .NET Framework 4.6.1 Standalone Redistributable Package + LangPack
Microsoft .NET Framework 4.6.2 Standalone Redistributable Package + LangPack
Версия Microsoft .NET Framework 4.6 является высокосовместимой заменой для Microsoft .NET Framework 4, .NET Framework 4.5, .NET Framework 4.5.1 и .NET Framework 4.5.2.
 
Microsoft .NET Framework 4.7
NDP47-KB3186497-x86-x64-AllOS-ENU.exe
Языковой пакет Microsoft .NET Framework 4.7  
NDP47-KB3186497-x86-x64-AllOS-RUS.exe
 

ВАЖНО! Решение проблемы неустановки обновления KB928416 на систему со всеми установленными фреймворками до 3.5 SP1 включительно (предположительно эта проблема возникает только на OEM-версиях XP) Более простое, но не радикальное решение проблемы через запись в реестре.
Прямая ссылка на netfx3-kb928416-v3.0-x86-rus


Утилиты для проверки корректности установки и удаления .NET Framework всех версий: Framework Setup Verification Utility и Framework Setup Cleanup Utility


 
Вариант шапки от ZX83 просьба потестить
 
Подробнее... Убрал инфу о том какая версия куда входит (дублируется списком в конце шапки) и старые версии 2.0 SP1, 3.0, 3.0 SP1 и 3.5. Все равно они уже никому не нужны. 2.0 оставил потому что нужна для Windows 9x. Если никто не против, просьба кому-нибудь прикрепить.

Репак от Gora

Microsoft .Net FrameWork 4.6.1 for Windows 7 SP1 [x86-x64]
Описание

Всего записей: 297 | Зарегистр. 21-02-2002 | Отправлено: 13:52 08-01-2004 | Исправлено: SergeyGolubev, 15:34 06-08-2017
AlxMonster



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Она вроде как все это в оперативе должна держать...
Не должна. Только куст HKEY_CURRENT_CONFIG полностью сидит в памяти.

Всего записей: 1414 | Зарегистр. 14-02-2006 | Отправлено: 19:39 28-09-2008
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
pytex

Цитата:
Сейчас о месте на винчестере не особенно приходится беспокоиться.

Не у всех крутые современные компы с огромными винчестерами, и не у всех есть возможность купить второй винчестер.
 
На старом винте 40 Gb присутствие какого-либо из  .NET (даже 1.1 и 2.0, не говоря о 3.0 и 3.5) весьма ощутимо - я бы предпочел занять это место чем-нибудь более полезным, чем библиотеки, используемые 2-3 редкоиспользуемыми прогами на компе...

Всего записей: 24358 | Зарегистр. 03-05-2004 | Отправлено: 19:44 28-09-2008
thelamb

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus

Цитата:
На старом винте 40 Gb присутствие какого-либо...  

Ну кто будет с этим спорить? Я ставил на 80-ку, да и то сейчас бы ещё подумал. Игры пошли по 12 Гб, вот их бы урезать. Понатыркают видео, графики, а про саму игру как то скромно забывают.  

Всего записей: 4801 | Зарегистр. 25-11-2004 | Отправлено: 19:59 28-09-2008
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
thelamb
Игр не держу, но даже на игры меньше жалко места, чем на .NET.

Всего записей: 24358 | Зарегистр. 03-05-2004 | Отправлено: 20:23 28-09-2008
puzvan



BANNED
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подскажите !!! Пожалуйста !!!  
У меня ХР SP3 - сборка из    
Хочу поставить на Живую систему это !
Нужно ли мне удалять установленную сборку или достаточно накатить поверху ?

Всего записей: 1223 | Зарегистр. 22-10-2006 | Отправлено: 20:49 28-09-2008
AlxMonster



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Джоэл очень хорошо написал про .net. На самом деле .net очень удобен для разработчика, сам на нем иногда пишу, но распространять такое приложение очень трудно.  
Сейчас,  в основном, для программ нужны фреймворки 2.0 и 1.1. Причем последний нужен все меньше и меньше. Новые версии программ постепенно переходят на 2.0. Жесткой необходимости в 3.0 и 3.5 я тоже не вижу в данный момент. Если сейчас программа потребует у меня фреймворк 3.0, то она просто пойдет лесом.

Всего записей: 1414 | Зарегистр. 14-02-2006 | Отправлено: 21:35 28-09-2008
puzvan



BANNED
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Накатил поверху - стало так ...
 

Всего записей: 1223 | Зарегистр. 22-10-2006 | Отправлено: 21:42 28-09-2008
Aalai

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
pytex

Цитата:
остались: 2-й и 3-й

Но способ наверное существует, как можно всё вычистить или нет ?
 
Кстати... до удаления, в VersionCheck.exe отображались NET Frameworkи с версиями, почему же они сменили имя ?

Всего записей: 996 | Зарегистр. 03-02-2007 | Отправлено: 23:27 28-09-2008
AlxMonster



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Про удаление здесь http://forum.ru-board.com/topic.cgi?forum=5&topic=10616&start=580#12

Всего записей: 1414 | Зарегистр. 14-02-2006 | Отправлено: 19:53 29-09-2008
niels



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
пожалуйста объясните?
при установке на чистую систему Microsoft .NET Framework 2.0 Service Pack 1 нужно ли предварительно установить Microsoft .NET Framework 1.1 Service Pack 1 или сразу можно начинать установку с NET Framework 2.0 Service Pack 1.?

Всего записей: 1526 | Зарегистр. 16-03-2007 | Отправлено: 22:40 29-09-2008
thelamb

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
niels
Не нужно. И вообще версии 1.0 и 1.1 уже не нужны.

Всего записей: 4801 | Зарегистр. 25-11-2004 | Отправлено: 22:47 29-09-2008
AlxMonster



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
framework 1.1 нужен для Visual Studio 2003, Borland Developer Studio 2006, Sound Forge 8 и некоторых других программ.

Всего записей: 1414 | Зарегистр. 14-02-2006 | Отправлено: 00:01 30-09-2008
niels



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
thelamb
ну вот видишь, а говоришь не нужен...
Sound Forgeм я иногда пользуюсь...
кто еще выскажет свое мнение на этот счет, а то противоречивые показания?
ставить или нет, пока еще не поставил..?

Всего записей: 1526 | Зарегистр. 16-03-2007 | Отправлено: 00:11 30-09-2008
AlxMonster



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Не ставить, пока какая-нибудь программа явно не потребует именно версию 1.1

Всего записей: 1414 | Зарегистр. 14-02-2006 | Отправлено: 01:05 30-09-2008
rupo

Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
при установке  dotnetfx3_x64.exe
выдает вот это
 
Error signature
EventType : wap10setup     P1 : 13856     P2 : 3.0.04506.30_waprtm_x64_sfx
P3 : mc     P4 : inst     P5 : f
P6 : ca_regtlb_mscorlib.tlb.3643236f_fc70_11d3_a53     P7 : -1     P8 : 1603
P9 : -     P10 : microsoft .net f
Reporting Details
This error report includes: information regarding the condition of setup.exe when the problem occurred,
the operating system version and computer hardware in use, and the Internet Protocol (IP) address of
your computer.
We do not intentionally collect your name, address, email address or any other form of personally
identifiable information. However, the error report may contain customer-specific information in the
collected data files. While this information could potentially be used to determine your identity, if
present, it will not be used.
The data that we collect will only be used to fix the problem. If more information is available, we will tell
you when you report the problem. This error report will be sent using a secure connection to a
database with limited access and will not be used for marketing purposes.
 
в чём может быть дело?

Всего записей: 583 | Зарегистр. 21-08-2004 | Отправлено: 20:59 30-09-2008
chogo



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
пожалуйста объясните?  
при установке на чистую систему Microsoft .NET Framework 2.0 Service Pack 1 нужно ли предварительно установить Microsoft .NET Framework 1.1 Service Pack 1 или сразу можно начинать установку с NET Framework 2.0 Service Pack 1.?

 
в довесок ещё вопрос: NET Framework 2.0 Service Pack 1 включает в себя простой NET Framework 2.0 или нужно вначале ставить 2.0 а потом SP1 сверху ?

Всего записей: 1196 | Зарегистр. 05-01-2003 | Отправлено: 09:52 01-10-2008
Colourban



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
chogo, потом SP1 сверху.


----------
Человек, способный разбудить спящего, способен на любую подлость.
Глядя на Вас, хочется ещё раз пожелать Вам здоровья!

Всего записей: 819 | Зарегистр. 09-12-2003 | Отправлено: 19:50 01-10-2008
thelamb

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Здесь всё на русском:
http://www.microsoft.com/downloads/Search.aspx?displaylang=ru
Тут же есть и поиск в правом верх. углу. А так же переход на любой другой язык.

Всего записей: 4801 | Зарегистр. 25-11-2004 | Отправлено: 22:53 01-10-2008
pytex



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
chogo, пост

Всего записей: 3693 | Зарегистр. 01-11-2006 | Отправлено: 23:14 01-10-2008
Diabolik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Вроде как 4-ой запахло.

Всего записей: 4471 | Зарегистр. 02-10-2004 | Отправлено: 15:12 05-10-2008
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137

Компьютерный форум Ru.Board » Компьютеры » Программы » Microsoft .NET Framework

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru