Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » VMware ThinApp (formerly Thinstall) часть 4

Модерирует : gyra, Maz

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53

Открыть новую тему     Написать ответ в эту тему

Geroy4ek

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Предыдущие части темы: 1, 2, 3
Смежный топик в Варезнике
 
VMware ThinApp  5.2.6
 
Официальный сайт | Форум | Описание | Список изменений | FAQ (PDF, Eng) | Обзор успешно упакованных программ | ThinApp Docs
 
ThinApp (ex Thinstall) используется для виртуализации приложений, позволяет заключить приложения в виртуальный контейнер и использовать их как готовые пакеты, не требующие установки. Внутри контейнера создается виртуальная среда для реестра и файлов.  
Поддерживаемые ОС:    
x32: Windоws 2000/XP/XPE/Server 2003/2008/2012/2012 R2/Vista/7/8/8.1/10  
x64: Windоws  Server 2003/2008/2008R2/Vista/7/8/8.1/10

Скачать программу можно в Варезнике

Полезные утилиты
 
FAQ, статьи, обзоры
 
Полезные ресурсы

Если при запуске готового приложения выскакивает окошко в трее, читайте шапку топика в Варезнике.
 
VMware ThinApp - обсуждение перевода
 
Русский перевод мануала по VMware ThinApp версии 5.1.0 + перевод справочника по параметрам Package.ini от pavlaf
 
Ближайший аналог: Spoon Studio (ex Xenocode Virtual Appliance Studio)

Всего записей: 1 | Зарегистр. 24-04-2015 | Отправлено: 17:26 24-04-2015 | Исправлено: DollHack, 13:45 21-09-2019
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator Была такая попытка, когда я хотел подключить плагин .NET Framework, собранный в пятой линейке к программе, собранной в 4.7.3 Получился облом. Иначе, я бы этого не писал...

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 08:11 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473
Какой Framework (ссылка) к какой сборке, можно поконкретней ?

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 08:34 26-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator

Цитата:
Какой Framework (ссылка) к какой сборке, можно поконкретней ?

 
Увы, не можно, так как я после того эксперимента был вынужден пересобрать фреймворки в тех версиях на которых были собраны программы. Так теперь всё и осталось согласованным. Жаль, но сейчас это лишь мои слова без доказательств...

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 10:37 26-04-2016 | Исправлено: AVanti 473, 13:32 26-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473

Цитата:
Ладно, всё путём, решение почти готово. Буду использовать в скрипте WinAPI

 
https://yadi.sk/d/W-Lbz39trJCQP
 
(очень подробное описание в архиве)
 
Теперь везде и всё работает, всё нормально! Пользуйтесь на здоровье, кому интересно!
 
Тестировалось: WinXP (реал, виртуальный контейнер ThinApp) и Win7 (реал, виртуальный контейнер ThinApp)

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 13:32 26-04-2016 | Исправлено: AVanti 473, 13:40 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473
Хорошо хоть
Цитата:
Жаль
, тут вот как всегда брякнул и пошёл, не утруждая себя какими-либо доказательствами.  
Все мои плагины, собранные в версии 4.7.3 (зачем собирать в 5.* - непонятно, тем более Framework) работают с программами, собранными в ThinApp 4.7.3 - 5.2.1. Исключения, конечно, могут быть, но не обязательно по вышеозвученной причине.

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 14:12 26-04-2016
Proshaa

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator
вам что-то доказывать = себя не уважать.  
"брякаю" снова. в какой-то момент, будучи на выезде, мне понадобился Framework. взял первый попавшийся. попался ваш. мой Corel, собранный в 5.1 с ним не заработал. "утруждать" себя разбирательствами и "доказательствами" не было ни времени ни желания, работать надо было. просто взял другой и с ним всё прекрасно заработало.
всё, что я "брякаю" - основано на личном опыте. имеющимися знаниями, предположениями и соображениями я открыто делюсь с сообществом.
от вас же конструктива что-то не видно.

Всего записей: 2831 | Зарегистр. 10-01-2011 | Отправлено: 14:44 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Proshaa
Вы обыкновенный болтун, не спорю - талантливый, выкручиваться и передёргивать умеете здорово, но не более того, всё остальное - вода и вилы, пишите дальше, всегда найдутся любители лапши на ушах, собственно, на них и рассчитана ваша "конструктивная" писанина.

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 17:41 26-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator

Цитата:
Все мои плагины, собранные в версии 4.7.3 (зачем собирать в 5.* - непонятно, тем более Framework) работают с программами, собранными в ThinApp 4.7.3 - 5.2.1.

 
Помню, что проверку я тогда свою начал именно с Вашего диалога с Proshaa. Мне показалось логичным, что нововведения в плагинах, собранных на пятой линейке (например те же папки %ProgramFilesDir(x64)% и %SystemSystem(x64)%) будут непонятны программе, собранной в 4.7.3 так как в старых версиях их ещё не было, и портабельный контейнер не сможет безошибочно слить всё в одну песочницу. Но, я честное слово, уже не помню как было. Сейчас глянул, у меня все плагины пересобраны в 5.1.1-2722044. Точно помню, что была именно несовместимость и именно с плагином фреймворка (толи второго, толи четвёртого). Ещё была хрень в проге Anvil Studio, где сперва и прога и плаг четвёртого фреймворка были собраны на 4.7.3 Не работала опция определения нот через микрофон. Когда пересобрал все свои плагины в 5.1.1-2722044, то прогу тоже пересобрал в 5.1.1-2722044 - всё заработало, но это уже не к конфликту плагинов относится, а к аксиоме, что пробовать всегда надо на разных сборках. Вобщем, это всё что я помню. Если когда-нибудь ещё замечу явные конфликты - сообщу.

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 18:49 26-04-2016 | Исправлено: AVanti 473, 18:53 26-04-2016
SunOK_ZM



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Вот вам наглядная иллюстрация, почему эту бяку (под кодовым названием .NF, VCR, silverlight, flash, java) легче установить на заре установки винды, чем выкручиваться с плагинами.
Ну а если попался под руки комп без оных - куда уж денешься от лотереи "взлетит / не взлетит".

Всего записей: 252 | Зарегистр. 19-02-2012 | Отправлено: 18:55 26-04-2016 | Исправлено: SunOK_ZM, 19:25 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473
Цитата:
Ещё была хрень в проге Anvil Studio, где сперва и прога и плаг четвёртого фреймворка были собраны на 4.7.3
Что-то я не увидел связь неработающей опции с плагином (в какой бы версии ТА он бы не собран), довольно много программ, собранных в 4.7.3 могут вообще не работать или работать не полноценно (Ваш случай), а при пересборке в 5.* - всё нормально, но плагин то здесь при чём ? У Вас есть сейчас эта Anvil Studio, собранная в 5.1.1 ? Скиньте посмотреть.
SunOK_ZM
У нормальных пользователей этот джентльменский набор, как правило, и установлен, но есть разгильдяи, а то и просто сектанты , по каким-то своим идейным соображениям категорически отказываются устанавливать, к примеру, Framework или набор библиотек. Они есть не где-то  там вообще, а здесь на форуме, встречал. Вот и приходится выдумывать костыли (по доброй воле, конечно).

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 21:20 26-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator

Цитата:
Что-то я не увидел связь неработающей опции с плагином

 
А её и нет, я сам же сказал следующее:
 

Цитата:
это уже не к конфликту плагинов относится, а к аксиоме, что пробовать всегда надо на разных сборках

 
Далее по поводу:
 

Цитата:
У Вас есть сейчас эта Anvil Studio, собранная в 5.1.1 ? Скиньте посмотреть.

 
Я человек честный, и не кривя душой скажу как есть: Эта версия купленная (полная). Я обещался её не распространять и хоть режьте - не дам.
 
Поверьте, мне нет смысла выдумывать. Рассказал с чем сталкивался лично, и что помню. Заранее прошу прощения за свои, на сегодняшний день, голословные утверждения. Если будут доказательства по теме - предоставлю. Пока, пусть будет Ваша правда и мои слова в качестве обычного мнения, не более того!

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 21:49 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473
Резня не предвидеться , но, может быть, хоть что-то есть собранное в последних версиях (выше 4.7.3) ТА и требующее какой-нибудь фреймворк для работы ?
P.S.Никакой моей правды не существует, существует утверждение в небезызвестном мануале, которого придерживаетесь Вы (и не только), я же на практике столкнулся с другим результатом, только и всего.

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 22:00 26-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator

Цитата:
хоть что-то есть собранное в последних версиях (выше 4.7.3) ТА и требующее какой-нибудь фреймворк для работы ?

Разве что приходит на память форджик http://avanti473.ru/news.php?readmore=95, требующий второй фреймворк, но, как видите, и там уже версия сборки плагина и программы синхронизированны на 5.1.1-2722044
Только, надо вспомнить в чём там затык с фреймворком. Тоесть работает форджик без него, или всего-лишь не работает некоторый функционал программы. Хотя нет, форджику ещё со старых версий второй фреймворк был жизненно необходим... Попробуйте. Но, Вы же помните как у меня собран портабл. Придётся потерпеть процедуру авторегистрации...

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 22:15 26-04-2016 | Исправлено: AVanti 473, 22:16 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473
Что там требуется для последней версии Sound Forge я тоже не помню, я использовал репак инсталлятора, он устанавливается и на ХР, библиотеки точно были нужны, про фреймворк не помню.

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 22:30 26-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Proshaa

Цитата:
всё по теме - в этой теме   http://forum.ru-board.com/topic.cgi?forum=35&topic=52322&start=4520#21

 
Ага, добрался...
 

 

 
Ладно, меня устраиват как собрался проект моего варианта фотошопа. Висячий процесс AdobeIPCBroker.exe убивается скриптом на ура, а от интернета кстати пришлось моё сегодняшнее, скриптовое решение. Бог с ним, с XP. Резать уже проект не буду, хай весит 700 метров, зато всё на борту (акромя полезностей для полиграфии, разумеется ). Теперь буду искать лёгкие плагины и делать их в формате AppLinks. К слову, понравился функционал 3D в новом фотошопе, надеюсь его освоить в будущем...

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 22:37 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473
Вот что получилось с Вашей библиотекой (без неё вообще нет запуска) и моим плагином. Честно говоря, сборка через ошибку запускается вообще без фреймворка, но как она поведёт себя дальше - не проверял. Главное, сборка 5.1.1 работает с плагином 4.7.3, что и требовалось выяснить.

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 22:51 26-04-2016 | Исправлено: conservator, 23:15 26-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator

Цитата:
Надеюсь, всё видно без комментариев

 
С комментариями... Не будем торопиться с выводами. Я вспомнил где там был затык. Прога запустится и будет работать даже без плагина фреймворка, но, выдаст такое предупреждение в процессе запуска:
 

 
Этот момент у меня в сборке учтён, и кнопа "ОК" там нажимается автоматом во время процедуры авторегистрации. Но, справедливости ради, ни на моём плагине фреймворка, ни на Вашем, такого сообщения не появляется. Тем не менее, если фреймворк для проги не критичен, такой опыт нельзя назвать показательным. Прошу прощения, что сразу всё не вспомнил - всё не упомнишь...
 
----------
 
Добавлено:
Ещё по поводу форджика. Даже у меня, в описании скриптовой версии инсталляции есть фраза:
 

Цитата:
3) Если в Вашей системе не установлен Microsoft .NET Framework v2 или v3.5 скриптовая установка применит временную заглушку, чтобы инсталляция прошла без проблем.

 
А это означало всего лишь, что в реестр, если я всё верно помню, будет внесена всего одна запись, вот и всё.
При мерже 5.1 и 4.7.3 допускаю, что реестр может объединиться, но вот файлы, в особенности из папок %ProgramFilesDir(x64)% и %SystemSystem(x64)% сильно сомниваюсь...
Таким образом, форджик оказался плохим примером. Результат мержа 5.1 и 4.7.3 всего-лишь показывает программе подобие моей заглушки и не более того. На работоспособности это никак не сказывается. Увы, надо искать что-то другое, которое без фреймворка и не запустится вовсе........  
 
Пока доказанно лишь то, что реестры объединяются у разных версий сборок и плагинов.

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 23:18 26-04-2016 | Исправлено: AVanti 473, 23:33 26-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
AVanti 473
Это означает, всего лишь, что Ваша версия Вам ближе, как своя рубашка, а ведь выбирал не я . Что тогда означает это: AirExplorer + необходимый ему плагин ?
Ещё один вариант: VideoThumbnailsMaker и плагин.

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 00:05 27-04-2016 | Исправлено: conservator, 00:24 27-04-2016
AVanti 473



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
conservator

Цитата:
Что тогда означает это:

Ладно, так и запишем - совместимость работает. Мержа реестра просиходит, мержа песочниц тоже. Оставляю за собой право сомневаться в том, что 4.7.3 поймёт и верно интерпретирует содержимое %ProgramFilesDir(x64)% и %SystemSystem(x64)%. Проверять уже не буду, так как слишком всё специфически и масса условий, которые проще повеситься, чем расписывать. Иначе это будет выглядеть как-то так:
"В случае подключения сборки Х1 (5.1.1) к сборке Х2 (4.7.3) в качестве плагина, файл xyz2.exe (находящийся по адресу.....) должен увидеть файл xyz1.exe (находящийся по адресу.....) в папке (x64) на системе x64 при условии таком-то, которое бывает (не бывает) в реальной жизни, либо, встречается не часто и посему не имеет принципиального значения"
И на эту хрень надо убить целый день.
По поводу неработающего фреймворка, вот ещё что вспомнилось. А такое может быть и не из-за версии ThinApp при сборке. Мы тут все дружно забыли, что фреймворки ещё имеют языковые пакеты. А некоторые программы, весьма капризны! Тот же форджик допустит в оборот не каждый фреймворк, даже в качестве заглушки. Не будет лангуаджпака, будет ошибка, а не использование eng языка. В результате, можно взять одну сборку фреймворка 4.7.3 и она не заработает с программой, собранной в 5.1.1, а можно, взять другую сборку фреймворка в той же 4.7.3, но, имеющую на борту нужный языковой пакет, и она заработает со сборкой 5.1.1. Это, между прочим, очень важный момент. Ведь, один человек ставит фреймворк из полного дистрибутива, другой, из набора "Дяди Васи", третий, отдельно из дистрибутива какой-нить английской софтины, не имеющей локализации и следовательно не требующей русский языковой пак для фреймворка при установке.
Думаю теперь всё прояснилось, и спор можно завершить навсегда.
 
P.S. Эх, память, память. Вспомнить бы всё раньше, и не было бы споров...

Всего записей: 366 | Зарегистр. 08-11-2015 | Отправлено: 18:01 27-04-2016 | Исправлено: AVanti 473, 18:01 27-04-2016
conservator



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Оставляю за собой право сомневаться в том, что 4.7.3 поймёт и верно интерпретирует содержимое %ProgramFilesDir(x64)% и %SystemSystem(x64)%.
А зачем вообще 32 битной сборке (программе) это папки ? Это же просто ненужный балласт, который просто удаляется из проекта. Если же сборка 64 битная, то и плагины соответственно тоже (за некоторым исключением, но фреймворк точно нужен 64 битный).

Всего записей: 4282 | Зарегистр. 08-11-2015 | Отправлено: 18:28 27-04-2016 | Исправлено: conservator, 18:30 27-04-2016
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53

Компьютерный форум Ru.Board » Компьютеры » Программы » VMware ThinApp (formerly Thinstall) часть 4

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru