Перейти из форума на сайт.


Система IP-видеонаблюдения "Линия". Скачать бесплатную демо-версию для 16 камер. НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Операционные системы » UNIX » Активные темы » Debian

Модерирует : ShriEkeR

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109

Открыть новую тему     Написать ответ в эту тему

dmitriyku

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

 
Debian GNU/Linux (Дебиан ГНУ/Линукс) — свободная универсальная операционная система, один из старейших дистрибутивов ГНУ/Линукса, ставший основой для наибольшего числа активных дистрибутивов, в их числе Убунту и Кноппикс.
 



 
 
Вашему RSS-агрегатору:
Записки дебианщика (http://mydebianblog.blogspot.com/)
Bappoy's blog (http://binsh.ru/)
Debian + Mate - записки применителя (http://ulyssesd.blogspot.ru/p/blog-page.html)
Настройка после установки Debian 9 (http://linuxoidblog.blogspot.ru)
 
Как настроить шрифты в Debian 8  
 
Дополнительные репозитории
Дебиан славится строгой лицензионной политикой, поэтому в официальном репозитории кое-каких вещей вы не найдете.


http://deb-multimedia.org
 
deb http://deb-multimedia.org jessie main non-free
deb http://mirror.yandex.ru/debian-multimedia/ jessie main non-free # зеркало
 
# aptitude install debian-multimedia-keyring # ключ

http://backports.debian.org/
 
deb http://backports.debian.org/debian-backports jessie-backports main
 
# aptitude install debian-backports-keyring # ключ

http://unofficial.debian-maintainers.org/
 
deb http://unofficial.debian-maintainers.org/ jessie main contrib non-free restricted
 
# aptitude install dmo-archive-keyring # ключ


Смело правьте и дополняйте шапку, однако не забывайте отписываться об исправлениях и сохранять исходный вариант под #.

Первый пост темы имел вид...

Всего записей: 87 | Зарегистр. 13-07-2007 | Отправлено: 18:38 04-07-2008 | Исправлено: jlmurat, 19:44 22-06-2017
mleo

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

RSEREGAR
 
Ставится. Работает.
 
> Расскажите, как заставить работать
 
Так вы обозначте в чем проблема.

Всего записей: 3534 | Зарегистр. 19-05-2004 | Отправлено: 23:46 31-08-2017
RSEREGAR



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
mleo
Не запускается

Всего записей: 293 | Зарегистр. 26-10-2008 | Отправлено: 17:44 08-09-2017
mleo

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

> Не запускается
 
Малоинформативно. Как устанавливали? Как запускаете? Что происходит при и после запуска?

Всего записей: 3534 | Зарегистр. 19-05-2004 | Отправлено: 00:04 09-09-2017
karavan



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
bearjrgm

Цитата:
С этим libssl в девятке сплощные проблемы, м.б. когда-то починят.  
Например вайбер из-за него отказывается ставиться  

Стало интересно, в чем проблемы с вибером, хотя и не являюсь его пользователем.
Как оказалось, деб-пакет вибера очень хочет видеть libssl1.0.0 и установленные версии 1.0.2 и 1.1.0 он игнорирует.
Даже не знаю как это комментировать, дебиан в этой ситуации в починке не нуждается, в отличии от вибера.
Но! Не смотря на ошибку установки:

Код:
viber depends on libssl1.0.0; however:
  Package libssl1.0.0 is not installed.

Все-же вибер запустился и мне удалось подтянуть на него когда-то зареганую учетку.
Честное слово, я пытался помочь виберу: создавал симлинки с либ 1.0.2, стрэйсил инсталляцию пакета, чтобы понять почему его симлинки не устроили (мне так и не удалось найти его попытки поиска либ), но все тщетно - в менеджере пакетов он так и остался "недоустановленным", хотя и в рабочем варианте.
 
Опыты проводил в Live-9.1.0.
Пишите багрепорты мэйнтейнерам вибера, пусть исправляют.
 
Добавлено:
Чуть позже, после выключения виртуалки, нашел это решение:
http://itplace.by/ustanovka-telegram-i-viber-v-debian-9/

Всего записей: 1135 | Зарегистр. 02-12-2011 | Отправлено: 23:46 12-09-2017
zz999

Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
karavan

Цитата:
Пишите багрепорты мэйнтейнерам вибера, пусть исправляют.

нечего там исправлять, все зависимости удовлетворяются из репозиториев,
DEBIAN/control:
--------------------------------------------------------------------
предлагаю "дебианщикам" мою сборку Debian 9 xfce amd64
сборка сделана для себя и до выхода Buster является моей настольной системой, as is...

Всего записей: 218 | Зарегистр. 07-01-2007 | Отправлено: 18:54 20-09-2017 | Исправлено: zz999, 20:29 20-09-2017
karavan



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
zz999

Цитата:
все зависимости удовлетворяются из репозиториев

 
dpkg --info viber.deb | grep -i depends
 
cat /etc/apt/sources.list | egrep -v '^#|^$'
 
apt search libssl
 
 

Код:
lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description:    Debian GNU/Linux 9.1 (stretch)
Release:        9.1
Codename:       stretch

 

Всего записей: 1135 | Зарегистр. 02-12-2011 | Отправлено: 21:21 20-09-2017 | Исправлено: karavan, 21:23 20-09-2017
RSEREGAR



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
karavan
Благодарю. С вашей помощью вайбер заработал.

Всего записей: 293 | Зарегистр. 26-10-2008 | Отправлено: 22:39 20-09-2017
zz999

Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
karavan
apt search libssl
хм, правда нету, у меня с jessie-backports, когда то ставил, для sstp-client, однако
apt-cache showpkg libssl1.0.0
viber работает без вопросов с ним...

Всего записей: 218 | Зарегистр. 07-01-2007 | Отправлено: 23:36 20-09-2017 | Исправлено: zz999, 00:29 21-09-2017
RSEREGAR



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Разве libssl1.0.0 не является уязвимым, небезопасным?
Ссылка

Всего записей: 293 | Зарегистр. 26-10-2008 | Отправлено: 15:30 21-09-2017
Skif_off

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подскажите, пожалуйста, можно ли как-то повлиять на мантейнеров пакетов?  
Начну издалека. Geany в репозитории почему-то долго не обновляется, а т.к. Ubuntu корнем уходит в сабж, полез в пакеты Debian и таки... был крайне изумлён, обнаружив в deb-файле строку
Depends: ..., libfontconfig1 (>= 2.12), ...
При этом даже в Ubuntu 17.10 на данный момент libfontconfig1 версии 2.11.94-0ubuntu2.  
В Debian версия библиотеки 2.12.3-0.2 только для buster (testing) и sid (unstable), для них же и Geany 1.31-1.
 
В итоге несколько версий дистрибутивов и куча производных тупо за бортом на пустом месте. Зачем так делать? Тут ограничение похоже на искуственное. Или неверно улавливаю причинно-следственную связь?
 
P.S. В 16.04 сейчас собрал Geany 1.31 и часть плагинов, которыми пользуюсь, с версией  2.11.94-0ubuntu1.1 и как-то проблем, я бы сказал, немного - ровно 0 (ну, 1: виртуалку загадил, без снимка). (Собрал без патчей отсюда, там в приницпе всякая мелочь, ничего кардинального.)

Всего записей: 4848 | Зарегистр. 28-01-2008 | Отправлено: 08:03 24-09-2017 | Исправлено: Skif_off, 08:04 24-09-2017
karavan



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Skif_off
Вам бы следовало разобраться с темой PPA, думаю, что на этом все ваши вопросы и требования утихнут.

Всего записей: 1135 | Зарегистр. 02-12-2011 | Отправлено: 13:23 24-09-2017
Skif_off

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
karavan
Вопросы есть, да, и непонимание тоже, требований нет. PPA особо ни при чём как будто: судя по содержимому, кто-то (это не официальный PPA Geany) берёт архив отсюда http://http.debian.net/debian/pool/main/g/geany/geany_1.31.orig.tar.gz, накатывает патчи отсюда http://http.debian.net/debian/pool/main/g/geany/geany_1.31-1.debian.tar.xz и собирает под несколько систем (последняя версия для примера), можете сравнить с соодержимым http://ppa.launchpad.net/geany-dev/ppa/ubuntu/pool/main/g/geany/geany_1.30.1-1~xenial1.debian.tar.xz.
Для 17.10 запилили версию 1.31-1, всё те же патчи из Debian, но libfontconfig1 нет в списке зависимостей, я с телефона, deb-файл под ведроидом, похоже, нормально не открыть, не вижу служебных файлов, только data.tar, но если верить ссылке - в 17.10 версия 2.11.94-0ubuntu2.
Сам я ни разу не программист, но таки залез в ченджлог fontconfig и не вижу ничего кардинального в переходе 2.11 -> 2.12: пара багов с номером (с баг-трекера, видимо), пара утечек памяти, удаление "unused code". И до крайней 2.12.6 тоже не особо, не говоря уже о том, что имеющаяся в 16.04 версия 2.11.94 в ченджлоге отмечена как "2.11.94 (2.12 RC4)"
Получается, что ноги растут из Debian, и требование libfontconfig1 >= 2.12 выглядит непонятно и, в сравнении, как-то... неоправданно, пожалуй.

Всего записей: 4848 | Зарегистр. 28-01-2008 | Отправлено: 15:14 24-09-2017
karavan



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Skif_off

Цитата:
PPA особо ни при чём

Сам ppa нет, но его суть в том, что там пакеты от неофициалов - кто хочет тот и выкладывает свои поделки.
И в этом контексте неуместны требования ни по корректности сборки, ни по срокам релизов.
Можете самостоятельно собрать пакет и указать в makefile удобные для себя зависимости.

Всего записей: 1135 | Зарегистр. 02-12-2011 | Отправлено: 18:40 24-09-2017
Skif_off

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
karavan
Где вы всё требования-то видите? Процитирую себя же

Цитата:
Подскажите, пожалуйста, можно ли как-то повлиять на мантейнеров пакетов?

патчи взяты из Debian и вижу там в зависимостях не очень оправданное требование libfontconfig1 >= 2.12, на офсайте Geany требования не очень высокие:

Цитата:
Requirements
 
You will need the GTK (>= 2.24) libraries and their dependencies (Pango, GLib and ATK). Your distro should provide packages for these, usually installed by default.

 

Цитата:
Можете самостоятельно собрать пакет и указать в makefile удобные для себя зависимости.

При чём тут для себя? И нафиг тогда нужны репозитории в пакетных дистрибутивах? Либо я неверно понял, как всё это работает с разными версиями ОС и софта, либо то, что свежая версия Geany есть только в buster (testing) и sid (unstable) с внезапно вылезшей явно указанной зависимостью libfontconfig1, ещё и >= 2.12, оказывает влияние. Сравните версии здесь и здесь: после того, как в в buster (testing) и sid (unstable) в пакете появилась зависимость libfontconfig1 >= 2.12, в PPA перестали собираться новые версии. При этом и там, и там сопровождающий Chow Loong Jin.
Или это как-то связано с циклами выпуска версий и мне можно только выпилить PPA, перепроверить зависимости и поставить deb-файлы отсюда? Это же странно как-то - всё, что мешает, это >= 2.12 Мой английский не так хорош, чтобы предварительно не попытаться прояснить всё это на родном и могучем.
 
Собрать не понял как, не силён в этом: там какие-то параметры для ./configure используются, т.к. из исходником ставится немного иначе, а в geany_*.debian.tar.xz в патчах и прочих файлах ничего. Или вся разница в том, что в Unix-like скомпиленное самостоятельно ставится в /usr/local и достаточно --prefix=/usr, не знаю.
 
P.S. Сейчас слил geany_1.31-1_amd64.deb для buster (testing), распаковал и все ELF-файлы скормил ldd: как и ожидал, всё в порядке, и, получается, пакет не встал на мою 16.04 только потому, что в control стоит Depends: ..., libfontconfig1 (>= 2.12), ....

Всего записей: 4848 | Зарегистр. 28-01-2008 | Отправлено: 00:23 25-09-2017
asvg



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Братья-дебианщики! Приходите за прогами, всё в одном месте, по категориям...
http://forum.ru-board.com/topic.cgi?forum=65&topic=4525&start=180

Всего записей: 265 | Зарегистр. 15-12-2015 | Отправлено: 05:08 25-09-2017
karavan



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Skif_off
Я неточно выразился, не требования, но возмущение некорректной сборкой наблюдается.
Но, повторюсь, на ppa выкладывают все, кому не лень, свои поделки.
Эти пакеты не прошли должного тестирования, если сравнивать с официальными репами.

Всего записей: 1135 | Зарегистр. 02-12-2011 | Отправлено: 11:48 25-09-2017
tt43

Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ребята, объясните новичку - как можно воспринимать наличие в системе unused packages ?
хорошо или плохо и как от этого уйти ?

Всего записей: 2020 | Зарегистр. 04-02-2014 | Отправлено: 15:19 04-10-2017
Alukardd



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
tt43
Ну по идеи это пакеты, которые когда-то были автоматически установлены как зависимости, но не были удалены, хотя тот из-за кого их ставили уже удалён.
Т.е. пакетный менеджер считает их "не используемыми".
1. Он далеко не всегда прав, так что всегда смотрите что он предлагает удалить.
2. Удалить можно командой apt autoremove (или apt-get если более привычно)

----------
Microsoft gives you windows, linuх gives you the whole house...
I've been using Vim for about 4 years now, mostly because I can't figure out how to exit it.

Всего записей: 6153 | Зарегистр. 28-08-2008 | Отправлено: 15:57 04-10-2017
ASE_DAG



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Alukardd
> apt autoremove  
> Он далеко не всегда прав, так что всегда смотрите что он предлагает удалить.
 
N. B.  У Аптитьюда более осторожное понимание неиспользуемого пакета.   Достаточное для того, чтобы он удалял их без особого приказа.

----------
Dmitry Alexandrov <321942@gmail.com>

Всего записей: 9103 | Зарегистр. 12-05-2005 | Отправлено: 21:03 04-10-2017
karavan



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
ASE_DAG

Цитата:
У Аптитьюда более осторожное понимание неиспользуемого пакета.

Видимо, у него куча других недостатков, если в дефолтной установке стрейтча его нет, но есть apt и apt-get.

Всего записей: 1135 | Зарегистр. 02-12-2011 | Отправлено: 21:51 04-10-2017
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109

Компьютерный форум Ru.Board » Операционные системы » UNIX » Активные темы » Debian

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2017

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru