Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » В помощь системному администратору » Как настроить VPN на CISCO 2611?

Модерирует : lynx, Crash_Master, dg, emx, ShriEkeR

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3

Открыть новую тему     Написать ответ в эту тему

enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Здравствуйте!помогите пожалуйста настроить впн на cisco 2611,желательно на каком нить примере.буду весьма благодарен.пытался настроить по мануалу с офсайта, как-то безрезультатно. Вся надежда на вас.

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 20:00 29-06-2007
slut



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
enito
Помочь не проблема, но вы не указали вообще никаких исходных данных.
Посему только прибилизительная базовая настройка:
 

Код:
 
!--Задаем политику Internet Key Exchange (IKE) и preshared key  
!--для соседа по тоннелю
 
!-Политика IKE для тоннеля
crypto isakmp policy 1
encr 3des
hash md5
authentication pre-share
group 2
!-Ключи для соседа
crypto isakmp key 123456 address 192.168.100.201
!
!!---Задаем параметры IPSec
!!---Они включают в себя соседей по тоннелю, типы протоколов,
!!---криптографические алгоритмы и описание трафика
crypto ipsec transform-set SAMPLE_SET esp-3des  
 
crypto map SAMPLE 10 ipsec-isakmp  
description Description of the crypto map statement policy
set peer 192.168.100.201
set security-association lifetime seconds 28800
set transform-set SAMPLE_SET
set pfs group2
match address 101
!
!
interface FastEthernet0/0
ip address 192.168.0.190 255.255.255.0
speed auto
full-duplex
!
interface Ethernet1/0
ip address 192.168.100.190 255.255.255.0
speed auto
full-duplex
!---Прилагаем crypto map на исходящий интерфейс тоннеля
crypto map SAMPLE
 
!-Определяем трафик, который будет направляться в тоннель
 
access-list 101 permit ip 192.168.0.0 0.0.0.255 192.168.3.0 0.0.0.255
access-list 101 deny ip any any
 

Для проверки работоспособности используются команды:

Код:
 
sh crypto isakmp sa - показывает все IKE SA  
sh crypto ipsec sa - все IPSec SA
 

 
Для поиска ошибок используются команды:  

Код:
 
sh crypto ipsec transform-set - показывает все возможные transform-set (они должны совпадать на обеих сторонах тоннеля)  
sh crypto map - показывает все crypto map
 

Детальный отлов ошибок при помощи дебаг-команд:  

Код:
 
debug crypto ipsec  
debug crypto isakmp  
debug crypto engine
 

Всего записей: 1813 | Зарегистр. 31-10-2002 | Отправлено: 12:45 30-06-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
огромное спасибо за помощь, какие данные нужно сказать(ip?).а эти настроички сейчас попробую.
 
У циски внешний ip-89.179.*.*
В локальной сети ip-192.168.10.0-192.168.10.255(все это раздаётся по DHCP)
 
И еще вопросик: когда пишем ключи для соседа что там за ip пишется, что за ip на фастэзернете0/0 и соответственно на 1/0?
 
 
Заранее благодарю. Вы мне считай жизнь спасли.
 
 
Добавлено:
огромное спасибо за помощь, какие данные нужно сказать(ip?).а эти настроички сейчас попробую.

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 15:28 02-07-2007 | Исправлено: enito, 15:40 02-07-2007
slut



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
enito
Во, уточните только задачу:  
что б юзеры через вашу 2611 выходили в инет соединяясь с ней через VPN-клиента ;
   или  
хотите шифровать трафик от 2611 до провайдерской железки? ;

Всего записей: 1813 | Зарегистр. 31-10-2002 | Отправлено: 09:22 03-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
через vpn будет подключаться другой офис к нашей сети для доступа к нашим серверам и прочей ерунде

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 11:20 03-07-2007
slut



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
enito
Перед настройкой надо точно представлять что как и через какую среду работает, есть ли привязка к маршрутам и пр. Посему уточните:  

Цитата:
У циски внешний ip-89.179.*.*

Удаленный офис будет подключаться через интернет?  
 

Цитата:
через vpn будет подключаться другой офис к нашей сети

В удаленном офисе тоже имеется cisco или каждый сотрудник этого офиса (а тогда, в принципе, в мобильном варианте из любого места) должен будет иметь возможность подключаться через интернет к вашей сети? Соответственно, будет и еще ряд уточнений, лучше свяжитесь по ICQ # 162181
 

Всего записей: 1813 | Зарегистр. 31-10-2002 | Отправлено: 12:20 03-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
удаленный офис подключается через интернет(в том офисе инет идет через сервак) в мобильном варианте каждый пользователь подключается с любого компа только под своим паролем и логином. если это реально.

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 13:50 03-07-2007 | Исправлено: enito, 13:55 03-07-2007
ipmanyak



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
enito Дался вам VPN. Кинь простой туннель ip-ip и всё! Делов на 5 минут.
interface Tunnel12  
 description ***  to main contora ***  
 bandwidth 128  
 ip address 192.168.5.1 255.255.255.252
 ip mtu 1400  
 no ip directed-broadcast  
 tunnel source ip_адрес
 tunnel destination ip_адрес  
 tunnel mode ipip
 


----------
В сортире лучше быть юзером, чем админом...

Всего записей: 9979 | Зарегистр. 10-12-2003 | Отправлено: 14:22 03-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
а поподробнее про эту штуку можно рассказать?и все дело в том что пользователь должен иметь возможность попасть в сеть из любой точки нашей огромной москвы,а может даже и дальше.вот по этому и хотелось бы поднастроить vpn.

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 14:34 03-07-2007 | Исправлено: enito, 14:37 03-07-2007
slut



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
ipmanyak
не пойдет по многим причинам (динамические адреса и маршруты, отсутствие безопасности).
 
Тут типичный вариант: нужно настраивать vpn на cisco и пропускать извне через какой-нибудь vpn-client типа Cisco VPN Client и, если по уму, то с аутентификацией на каком-нибудь RADIUS-сервере.
 
enito
Завтра постараю расписать детально

Всего записей: 1813 | Зарегистр. 31-10-2002 | Отправлено: 15:08 03-07-2007
ipmanyak



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
enito Тогда я не понял. Вам туннель нужен или циска в качестве VPN сервера ? И клиенты из винды будут ходить на вашу циску? И сколько клиентов ? Если много, то 2611 может не потянуть !


----------
В сортире лучше быть юзером, чем админом...

Всего записей: 9979 | Зарегистр. 10-12-2003 | Отправлено: 15:11 03-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
расказываю.Сейчас циска только распределяет интернет по одному нашему офису, на ней настроен DHCP и он раздает ip нашим офисным пользователям и есть необходимость дать доступ(ко всем компам) в нашу сеть другому офису(там примерно человек 5-8 постоянных пользователей которым нужен доступ к нашей сети).это в кратце.

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 15:46 03-07-2007
Elaniel



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
enito

Цитата:
есть необходимость дать доступ(ко всем компам) в нашу сеть другому офису

В этом другом офисе есть циска с поддержкой VPN-туннеля или нет?

Всего записей: 628 | Зарегистр. 08-10-2002 | Отправлено: 18:03 03-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
нет, там все идет через сервак под виндовс 2003 и керио.

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 18:21 03-07-2007 | Исправлено: enito, 18:32 03-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
кудато все пропали..... ((

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 15:03 04-07-2007
SurfKoba

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
A что вы рассказывали там про мигрующих по всей Москве пользователях?
Задача просто распадается на 2-связь офис-офис(хотя с Керио и это думаю будет не так просто как написано выше) и удаленный доступ мобильных юзеров
 
Добавлено:
A что вы рассказывали там про мигрующих по всей Москве пользователях?
Задача просто распадается на 2-связь офис-офис(хотя с Керио и это думаю будет не так просто как написано выше) и удаленный доступ мобильных юзеров

Всего записей: 802 | Зарегистр. 22-10-2002 | Отправлено: 20:53 04-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Сейчас хотелосьбы настроить связь между офисами, а спользователями попробую разобраться сам.Еще такой вопрос: если настроить vpn на cisco можно ли будет законнектиться к ней с помощью cisco vpn клиент любому пользователю?  
Еще раз всех благодарю за помощь)

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 23:58 04-07-2007 | Исправлено: enito, 10:03 05-07-2007
SurfKoba

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
enito
Что сложнее(пользователи или vpn между офисами) вопрос еще...
Там вы еще писали что то про то что удаленный офис пользоваться inet-ом через ВПН,или я чего не так понял...
Таки объясните всю задачу целиком.

Всего записей: 802 | Зарегистр. 22-10-2002 | Отправлено: 11:25 05-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
есть два офиса, в первом офисе находится главный сервак и прочие компы(здесь же стоит и циска) и из второго офиса надо получить доступ к этому серваку и компам.в принципе вся задача.

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 17:48 05-07-2007
enito



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
куда все опять пропали??? (((

Всего записей: 48 | Зарегистр. 22-06-2005 | Отправлено: 14:59 11-07-2007
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3

Компьютерный форум Ru.Board » Компьютеры » В помощь системному администратору » Как настроить VPN на CISCO 2611?

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru