Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Тематические » Системы управления сайтами » Проблема с MediaWiki

Модерирует : Antuan

 Версия для печати • ПодписатьсяДобавить в закладки

Открыть новую тему     Написать ответ в эту тему

xlsx2007



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Собственно судь проблемы.  
Теги <td><tr>(возможно и другие) что-то не работают.
 
Допустим если вставить этот текст:
<tr><td style="background-color: #d1dbdf; font-size:120%; text-align: center;" colspan="2">Рейтинг на основании нескольких рецензий</td></tr><tr><td style="background-color: #e8f4f8;">Агрегатор</td><td style="background-color: #e8f4f8;">Рейтинг</td></tr><tr><td>Game Rankings</td><td>PC: 75.43%[39]
Xbox 360: 76.59%[40]
PS3: 74.71%[41]</td></tr><tr><td>Metacritic</td><td>PC: 77/100[42]
Xbox 360: 74/100[43]
PS3: 75/100[44]</td></tr>
 
в статью на Wikipedia.org, mediawiki.org, traditio.ru.  
 
То при просмотре получится табличка!
 
а если вставить его же  в статью на lurkmore.ru, sysadminwiki.ru то при просмотре статьи собственно будет не табличка, а код.. такой же какой и вставляли.
 
Но это я для наглядности. Так вот у меня оно отображается также как и на lurkmore.ru, sysadminwiki.ru а мне надо чтобы теги сработали как на википедии.
 
Потому что из-за этого криво работает парсер.
 
Не думаю что на википедии и традиции тупо включены все html теги. Уверен где-то есть какая то настройка, которую я найти не могу.
 
Пробовал устанавливать расширения такие же как на традиции, но не помогло.  
 
Очень рассчитываю что кто-то сможет помочь!
 
Добавлено:
В общем.. разобрался сам.  
 
Файл Sanitizer.php отвечает за то каким тегам быть и как им быть, немного снизил ограничения для <tr> и <td>.

Всего записей: 78 | Зарегистр. 20-06-2008 | Отправлено: 00:48 03-10-2010
eltariya

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Нашел более проще вариант в LocalSetting.php вставить $wgUseTidy = true;
И все будет работать)

Всего записей: 1 | Зарегистр. 17-02-2011 | Отправлено: 03:27 17-02-2011
Открыть новую тему     Написать ответ в эту тему

Компьютерный форум Ru.Board » Тематические » Системы управления сайтами » Проблема с MediaWiki


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru

Рейтинг.ru