Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » Проверка на вирусы почтовых сообщений в The Bat

Модерирует : gyra, Maz

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

Открыть новую тему     Написать ответ в эту тему

murzik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Black_Hawk
где они были неправильно прописаны? В реестре?
Просто у меня вылезла аналогичная ошибка при переходе с билда 4.5.094 на 4.5.104
KAV Workstation

Всего записей: 3268 | Зарегистр. 03-07-2002 | Отправлено: 16:08 03-12-2004
murzik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
у кого нибудь работает com-based plugin в KAV 4.5.104 ?

Всего записей: 3268 | Зарегистр. 03-07-2002 | Отправлено: 15:57 06-12-2004
biomednet



Schwarz Meister
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
murzik

Цитата:
у кого нибудь работает com-based plugin в KAV 4.5.104 ?

Прекрасно работает. А что? В шапке программы The Bat FAQ по этому вопросу.
Хорошо бы и здесь прибить шапку.


----------
"...ибо такова есть воля Божия, чтобы мы, делая добро, заграждали уста невежеству безумных людей" (1Пет.2:15)

Всего записей: 2180 | Зарегистр. 12-08-2002 | Отправлено: 17:48 06-12-2004 | Исправлено: biomednet, 17:51 06-12-2004
murzik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
biomednet

Цитата:
Прекрасно работает. А что?

рассказываю более подробно.
Был установлен KAV Workstation 4.5.94, в нем все прекрасно работало.
Установил KAV Workstation 4.5.104
При попытке в TheBat "добавить Антивирус Касперского (TM)", выдается сообщение
"Невозможно инициализировать антивирусный модуль AVP COM plugin". Пробовал переставлять KAV с чисткой реестра - не помогло. При откате на билд 094 все работает.
У тебя точно KAV 4.5.104?
фак читал, но не нашел ничего для моего случая.

Всего записей: 3268 | Зарегистр. 03-07-2002 | Отправлено: 18:05 06-12-2004 | Исправлено: murzik, 18:09 06-12-2004
biomednet



Schwarz Meister
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

 murzik
 
FAQ по The Bat!
 
http://forum.ru-board.com/topic.cgi?forum=2&topic=1489#1
 
8.  Работа с антивирусами  
---  
8.1 Q: Как подключить в TheBat! версий 2.x/3.x проверку на вирусы как с установленными KAV версий 4 или 5?  
 
 
Добавлено
murzik
как подключал? через The Bat - Добавить модуль или как описано в FAQ через INI файл?


----------
"...ибо такова есть воля Божия, чтобы мы, делая добро, заграждали уста невежеству безумных людей" (1Пет.2:15)

Всего записей: 2180 | Зарегистр. 12-08-2002 | Отправлено: 18:10 06-12-2004
murzik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
biomednet

Цитата:
как подключал? через The Bat - Добавить модуль или как описано в FAQ через INI файл?

Раньше у меня было проблем с подключением плагина.
Сейчас проделал заменил модули и выполнил батник, файл ini не редактировал (в нем все это уже было). Плагин заработал
Спасибо.

Всего записей: 3268 | Зарегистр. 03-07-2002 | Отправлено: 18:37 06-12-2004
Marfa



Стихийное бедствие
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
korn32

Цитата:
А Нортон разве не проверяет без плагинов весь почтовый трафик? Или в корпоративном этой функции нет?

Стоит Norton SystemWorks, как он проверяет исходяю почту вижу, а как входящую нет. Так он все таки проверяет входящую почту или нет?

Всего записей: 635 | Зарегистр. 28-01-2002 | Отправлено: 22:46 06-12-2004
Marfa



Стихийное бедствие
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Вроде бы проверяет во всяком случае я заметила окно, при входящей почте, но исходящую почту он проверяет дольше...Почему?

Всего записей: 635 | Зарегистр. 28-01-2002 | Отправлено: 22:58 11-12-2004
wizard_vrn



Full Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Прочитал последние 3 страницы, пробовал различные способы.
НИЧЕГО НЕ ПОЛУЧИЛОСЬ! НЕ ВИДИТ МЫШКА КАСПЕРА!
The Bat! v.3.0.1.33+KAV 5.0.277
 
Файла AVConfig.ini нет НИГДЕ, НИ ПОД какими учетными записями, создавал вручную не помогло!
 
Кто нибудь может помоч? FAQ прочел весь.

Всего записей: 529 | Зарегистр. 29-04-2004 | Отправлено: 21:16 01-01-2005
murzik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
wizard_vrn

Цитата:
Кто нибудь может помоч? FAQ прочел весь.

у тебя путь к базам прописан в реестре?

Всего записей: 3268 | Зарегистр. 03-07-2002 | Отправлено: 23:27 01-01-2005
SVDouble

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
wizard_vrn
Аналогичные проблемы, но только KAV 4.5 . В ХР этот плагин подключается, но не работает, в том смысле что не удаляет инфицированные письма с  сервера, нужно их чистить ручками-полня фигня. А в W2K непонятно как его подключить, на одних машинах он подключается, на других нет, но тоже не работает. Пути к базам естественно прописаны в реестре при установке KAV

Всего записей: 33 | Зарегистр. 23-05-2003 | Отправлено: 15:26 14-02-2005
biomednet



Schwarz Meister
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
wizard_vrn

Цитата:
KAV 5.0.277  

У 5 KAV другой механизм проверки почты плагин не нужен.
Идет прямой перехват по POP3 протоколу.


----------
"...ибо такова есть воля Божия, чтобы мы, делая добро, заграждали уста невежеству безумных людей" (1Пет.2:15)

Всего записей: 2180 | Зарегистр. 12-08-2002 | Отправлено: 15:31 14-02-2005
Gleb77



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
wizard_vrn
 
The Bat! 1.60h + KAV Personal Pro 4.5.104 + W98SE
1. Залил kav40119 в директорию антивиря
2. Запустил register.bat (1-я комманда - ok, 2-ве другие: имя комманды или файла указаны неправильно)
3. Поискал AVConfig.ini - не нашел
4. В The Bat! попробовал подключить plug-in  - ok
5. Поискал  AVConfig.ini -> C:\Program Files\The Bat!\MAIL\AVConfig.ini - есть (в нем все как надо)
 
может AVConfig.ini создается при подключении плагина ...
 
попробовал проверил на вирусы - нашел - удалил
 
погляжу как будет работать дальше ...

Всего записей: 421 | Зарегистр. 08-04-2003 | Отправлено: 21:21 15-02-2005
murzik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Gleb77

Цитата:
The Bat! 1.60h + KAV Personal Pro 4.5.104


Цитата:
погляжу как будет работать дальше .

у меня эта версия под Win 2000 работает нормально, а для 5.0 надо путь к базам прописать в реестре.

Всего записей: 3268 | Зарегистр. 03-07-2002 | Отправлено: 22:32 15-02-2005
Gleb77



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
murzik
The Bat! 1.60h + KAV Personal Pro 4.5.104 + W98SE - стоит и работает
 
1. снес KAV Personal Pro 4.5.104 без остатка (по крайней мере на файловой системе, в реестре наверное тоже)
2. поставил KAV Personal 5.0.227
3. Залил kav40119 в директорию антивиря. Запустил register.bat  
4. В The Bat! попробовал подключить plug-in  - ok  
 
может The Bat! 1.60h + KAV Personal 5.0.227 + W98SE надо проверять на чистой системе?
 
1. Снес The Bat! 1.60h, поставил The Bat! 2.12
2. В The Bat! попробовал подключить plug-in  - ok  
 
The Bat! 2.12 + KAV Personal 5.0.227 + W98SE - работает
 
далее
 
1. Снес The Bat! 2.12, поставил The Bat! 3.0.1.33 Pro
2. В The Bat! попробовал подключить plug-in  - требуется bav-модуль
 
The Bat! 3.0.1.33 Pro + KAV Personal 5.0.227 + W98SE  - удалось заставить
 

Всего записей: 421 | Зарегистр. 08-04-2003 | Отправлено: 15:13 16-02-2005 | Исправлено: Gleb77, 14:59 17-02-2005
Gleb77



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Выводы:
 
На Windows98SE, для KAV Personal Pro 4.5.104, KAV Personal 5.0.227 имеем:
 
Для TheBat! версий 1.x/2.x/3.x  
- Копируем содержимое "4.0.1.19" в папку  
  с установленным Kaspersky Anti-Virus (или в любую папку, например: ..\The Bat!\KAV\);  
- Запускаем файл register.bat;  
 
Для TheBat! версий 1.x/2.x/3.x  
-  Копируем файл AVConfig.INI в C:\TheBat!; C:\Program Files\The Bat!\MAIL  
   (в ту папку, где находятся почтовые ящики !!!!!!)
 
   
Запускаем TheBat! добавляем плагин
и видим в настройках, что плагин подключён и имеет версию 4.0.1.19
 
AVConfig.INI:
 
[General]
CheckOpenAttach=1
CheckMail=1
SendNotify=0
NotifyTemplate=Attention!\0D\0A\0D\0A\20\20It\20seems\20you\20have\20got\20a\20virus\20on\20your\20machine!\0D\0A\20\20Please\20make\20sure\20you\20have\20the\20latest\20update\20of\20your\20virus\20scanner\0D\0A\20\20and\20check\20all\20your\20files\20right\20away!\0D\0A\0D\0ATake\20care,\0D\0A\20%OFROMNAME\0D\0A
Action=4
 
[Checkers]
Count=1
Checker #1=TAVP_Checker.

Всего записей: 421 | Зарегистр. 08-04-2003 | Отправлено: 15:00 17-02-2005 | Исправлено: Gleb77, 17:28 17-02-2005
str

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
У кого-нибудь появиласть ошибка инициализации (в меню "Защита от вирусов" kav со знаком вопроса). Появляется только со свежими базами. Если установить comul от 4 марта 05 - все ok. Как только обнавляешься - ошибка. Пробовал daily за последние 3 дня. Проявляется на разных машинах. Как откатываешься на comul Ok.
Везде Win2000sp4 Eng, AVP 4.5.0.104 Pro, kav40119, TB3.0.2.10

Всего записей: 168 | Зарегистр. 27-03-2004 | Отправлено: 12:17 10-03-2005
ssi



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Народ, не знаю с чем это связано: пытался вчера на одной машине прикрутить плагин касперского (5.0.227) к бату (3.02.10), так вот ни в какую он не хочет цепляться. Прописал что нужно в AVConfig.ini и в реестре пути прописаны, а бат выдает Версия - ?, Статус - Ошибка. Ну ладна, думаю, свалил все на заморочки установки.  
Дак нет, прихожу сегодня на работу, обновил каспера и тоже самое - до этого уже давно нормально работающий плагин тоже отпал.
 
И еще, в последнее время когда на каспере устанавливаешь "уровень постоянной защиты" на рекомендуемый, т.е. когда проверяются исходящие почтовые сообщения, очень часто письма не уходят. Вылазит ошибка. Я пробовал через разные SMTP сервера отправлять. Им, насколько я понял, не нравится заголовок письма после проверки его каспером. Если поставить "Максимальнау скорость" то все нормально.  
 
 
str  
 
когда писал твоего поста еще не было, но похоже это тоже самое

Всего записей: 665 | Зарегистр. 19-11-2002 | Отправлено: 13:37 10-03-2005 | Исправлено: ssi, 13:45 10-03-2005
murzik



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
str

Цитата:
У кого-нибудь появиласть ошибка инициализации (в меню "Защита от вирусов" kav со знаком вопроса). Появляется только со свежими базами. Если установить comul от 4 марта 05 - все ok.

аналогичная ошибка - TheBat 2.10.03, причем ошибку обнаружил прочитав твой пост.
Раньше все было нормально.

Всего записей: 3268 | Зарегистр. 03-07-2002 | Отправлено: 13:51 10-03-2005
Serg0FFan



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подтверждаю..та же фигня с установленным KAV for WKS 5.0.177...и The BAT! 3.0.2.10...
пробовал заноГо регить модуль для бата...пути проверил..всё правильно.. Похоже дело в самих базах...=))  
 
Добавлено:
ММмммммммммммать...(сорри) проблема в ключе который идёт с плагином...
Expiry Date 05.03.2005...приехали..все дружно ищем ключик!
 
Добавлено:
Нужен ключик у которого как минимум есть две записи которые можно увидеть кейвьювером:
ID=32 Kaspersky Anti-Virus Updater  
И
ID=54 Kaspersky Anti-Virus External API
.... есно не просроченые

Всего записей: 3019 | Зарегистр. 25-12-2002 | Отправлено: 14:47 10-03-2005
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16

Компьютерный форум Ru.Board » Компьютеры » Программы » Проверка на вирусы почтовых сообщений в The Bat


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru