Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » Расширения для Firefox (Mozilla Firefox Extensions) часть 6

Модерирует : gyra, Maz

articlebot (15-10-2014 12:58): Переезжаем в следующую часть:
Расширения для Firefox (Mozilla Firefox Extensions) часть 7.
 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302

   

batva



crazy administrator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
История темы: Предыдущие части

Обсуждение работы расширений к браузеру Mozilla Firefox, их совместимость, новые версии и т.п.
Обсуждение работы самого браузера Firefox осталось здесь.
Обязательно указывайте версию браузера, для которого описывается проблема.
Убедительная просьба выкладывать ссылки на домашние страницы расширения (или на страницы локализаций), а не прямые ссылки на сами xpi-файлы.
 
Уважаемые участники, просим вас не путать Плагины (Plugins) и Расширения (Extensions). Подробнее о разнице...
 
Начинающим и продолжающим "искателям" – краткий обзор некоторых расширений на ixbt.com (на "хоботе").
 
Расширения для Firefox и способы улучшения функциональности:
 
Поиск на сайте (Bookmarklets)
 
XYZProxy Расширение для работы с прокси (качаем) (читаем)
 
Tab Mix Plus. Финальная версия - Tab Mix Plus 0.4.1.5.2, работает с Firefox: 17.0 – 32.0 (от 30.09.2014) Последние сборки автора на его официальном сайте.
Последняя тестовая сборка - Tab Mix Plus Dev (Firefox 18.0 - 32.0).
 
Ru-Board Navigation. Версия 2011.11.15 от 15.11.2011. Расширение для лёгкой навигации по компьютерному порталу и форуму Ru-Board.com.  
Ru-Board bookmarks checker. Расширение для автоматической проверки обновлений закладок руборда.
 
Список расширений, имеющих побочные проблемы, и способы избавления от этих проблем (см.тут) + похожий список проблемных расширений
 
С просьбами и пожеланиями по русификации расширений обращайтесь сюда
 
Часто задаваемый вопрос: У меня Firefox поджирает память
 
MozBackup это не расширение, а программа для быстрого сохранения и восстановления закладок, всех настроек браузера и расширений: читаем .  
 
Расширение для сохранения страниц в формате MHT: UnMHT.
 
Кстати, обратите внимание: в теме Браузерные войны 2014 (Windows) Участвовать там в полемике никто не просит, но... проголосовать за Firefox надо всем кто пользуется Firefox'ом и кому он оказался полезен.
 
Решение проблем с несовместимостью расширений с текущей версией Firefox:
1) Как включить режим принудительной совместимости в Firefox?. Первый способ.
2) Включение принудительной совместимости дополнений с новыми версиями ПО. Второй способ.
3) Расширение Nightly Tester Tools - поможет попробовать заставить работать расширение, если оно выдаёт сообщение о несовместимость версий.  
4) Расширение MR Tech's Toolkit - поможет убрать несовместимость расширений с вашей версией Firefox, а также имеет много других полезных опций.
Однако будьте внимательны, и перед установкой новых расширений резервируйте свои данные.

Всего записей: 12593 | Зарегистр. 07-01-2001 | Отправлено: 15:30 22-11-2011 | Исправлено: Nilslis, 16:30 08-10-2014
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus 20:55 01-02-2012
Цитата:
почему в финале 10-ки отвалилось столько расширений
У меня ничего не отвалилось)
WatsonRus 20:55 01-02-2012
Цитата:
Это ведь то самое, что должно предотвращать отваливание?
extensions.checkCompatibility.10.0;false никто не отменял. extensions.strictCompatibility - это нечто другое.
WatsonRus 20:55 01-02-2012
Цитата:
Причем на 10 бета 5 все эти расширения прекрасно пашут.
Не знаю, никакой разницы не заметил в этом плане, между 10.0b1 - b6 и 10.0
 
 


----------
Инструкция по выживанию для баранов, пингвинов и пр., в зимнее время

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 21:10 01-02-2012
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka
Да уже все, разобрался. Предыдущий пост уже поправлен.
 
Но без бубна с Фоксом тоже никуда, как и с Оперой.
 
P.S. А FF 3.6 работает... работает... работает... до апреля еще далеко, да и там вилми на воде... 3.6 уже столько раз хоронили, что не счесть.
 
Добавлено:
21:10 01-02-2012
Цитата:
extensions.strictCompatibility - это нечто другое

Это именно то, что пришло на смену extensions.checkCompatibility.10.0;false, в соединении с парой других бубнов, указывающих минимальную версию и движок.
 
Добавлено:
21:10 01-02-2012
Цитата:
У меня ничего не отвалилось

Потому что используются новые расширения, а у меня полно старых, не обновляющихся сто лет, но нужных мне. Как выставил минимум 3.6 и движок 1.9 все принялись и работают как миленькие.

Всего записей: 25547 | Зарегистр. 03-05-2004 | Отправлено: 22:05 01-02-2012
Johnik



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus

Цитата:
P.S. А FF 3.6 работает... работает... работает... до апреля еще далеко, да и там вилми на воде... 3.6 уже столько раз хоронили, что не счесть.  

Посидев несколько дней на 9, могу сказать, что баланс в ее пользу в противостоянии с 3.6 отнюдь не так легко свести. Ну разве только нердское самолюбие потешить.
 
P.S. А, помимо пары расширений, я с этим переходом еще и любимой темы оформления лишился.

Всего записей: 919 | Зарегистр. 12-10-2002 | Отправлено: 22:30 01-02-2012 | Исправлено: Johnik, 22:32 01-02-2012
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus 22:05 01-02-2012
Цитата:
Потому что используются новые расширения, а у меня полно старых, не обновляющихся сто лет, но нужных мне. Как выставил минимум 3.6 и движок 1.9 все принялись и работают как миленькие.
У меня тоже старые есть, BBcode, например. Я думаю, что extensions.checkCompatibility вполне достаточно; можно без этого обойтись:
Цитата:
extensions.minCompatibleAppVersion;3.6
extensions.minCompatiblePlatformVersion;1.9

 
p.s. вот на nightly 13.0a1 сейчас реально фигня с расширениями творится , и не только у меня

----------
Инструкция по выживанию для баранов, пингвинов и пр., в зимнее время

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 23:26 01-02-2012
NONONINI

BANNED
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka 23:26 01-02-2012
Цитата:
p.s. вот на nightly 13.0a1 сейчас реально фигня с расширениями творится   , и не только у меня

А что с ними? У меня все работают.

Всего записей: 5150 | Зарегистр. 15-04-2009 | Отправлено: 23:45 01-02-2012
Ronin666



Silver Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
NONONINI 23:45 01-02-2012
Цитата:
А что с ними? У меня все работают.

Аналогично. Все работают...    

----------

Всего записей: 3295 | Зарегистр. 27-11-2007 | Отправлено: 00:07 02-02-2012
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
NONONINI 23:45 01-02-2012
Цитата:
А что с ними?
FlashBlock отвалился и еще то же, что и здесь наблюдается... Впрочем, возможно это связанные траблы, из-за этого: Bug 723154 - Some Flash objects don't work if content policies (Adblock Plus, NoScript, GreaseMonkey etc.) are present.
 
p.s. проблема с http://comed.in только на win есть; в линухе все норм.
 
Добавлено:
Вот совет, кстати, на эту тему:
Цитата:
Тем, кто хочет иметь 13.0a1 и корректно работающий флеш-контент...
 
Поставил сборку IonMonkey:
http://ftp.mozilla.org/pub/mozilla.org/firefox/tinderbox-builds/ionmonkey-win32/1328088032/firefox-13.0a1.en-US.win32.zip
 
- все нормализовалось...

 
Добавлено:
Поставил IonMonkey - с флешем все в порядке стало, проблемы пропали. Ладно, завязываю тут оффтопить, пока пуристы не набижали  

----------
Инструкция по выживанию для баранов, пингвинов и пр., в зимнее время

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 00:14 02-02-2012
jhgsds

Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
kwintos

Цитата:
firebug? может с помощью его натий проблему в расшироение Personal Titlebar которое не отображается в найтли 12 версии  

Нет конечно, Firebug не для этого.  
Изменённые настройки браузера и расширений хранятся в prefs.js, настройки панелей в localstore.rdf. Удаление этих файлов сбрасывает соответствующие пункты к дефолтным.

Всего записей: 494 | Зарегистр. 01-03-2011 | Отправлено: 00:47 02-02-2012
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka 23:26 01-02-2012
Цитата:
Я думаю, что extensions.checkCompatibility вполне достаточно; можно без этого обойтись:

Можно. Только зачем? Этот новый комплект бубнов для того и сделали, что бы с каждой новой версией не править циферки в extensions.checkCompatibility. Сейчас один раз поправил, и все - на века (коли новую хрень не придумают).
 
Но например Mr Tech Link Wrapper пришлось все равно ручками править - потому как у него интервал мин/макс 1.0 -3.1бета. А ведь реально до сих пор пашет, зараза.

Всего записей: 25547 | Зарегистр. 03-05-2004 | Отправлено: 11:44 02-02-2012
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus 11:44 02-02-2012
Цитата:
Можно. Только зачем? Этот новый комплект бубнов для того и сделали, что бы с каждой новой версией не править циферки в extensions.checkCompatibility. Сейчас один раз поправил, и все - на века (коли новую хрень не придумают).    
Да ну, делов то, раз в полтора месяца поправить А в ночнушках и править ничего не нужно.
 
p.s. есть у меня смутные сомнения, что этим "extensions.strictCompatibility" еще сильней нубов запутают

----------
Инструкция по выживанию для баранов, пингвинов и пр., в зимнее время

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 14:31 02-02-2012
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka 14:31 02-02-2012
Цитата:
есть у меня смутные сомнения, что этим "extensions.strictCompatibility" еще сильней нубов запутают  

Если они юзают только новые расширения (с мин версией 4.0+), им вообще ничего не придется править, все по умолчанию.
 
Добавлено:
А все старые распространенные постоянно обновляются, с ними тоже проблемы нет.

Всего записей: 25547 | Зарегистр. 03-05-2004 | Отправлено: 17:58 02-02-2012
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus 17:58 02-02-2012
Цитата:
им вообще ничего не придется править, все по умолчанию.  
Как то так:
Цитата:
lazuta пишет:
 
    MmM пишет: Мне все равно какая там циферка, хоть 154. Утомляет свистопляска с дополнениями после каждой "новой улучшенной версии".Вы сам пост принципиально не читали? Цитирую: "Большинство дополнений теперь по умолчанию совместимы с Firefox".
 
Читать я и сам умею. Спасибо. Обойдусь без цитат.  Если бы все было хорошо после обновления до 10-й версии то наверное я не зашел бы сюда по возмущаться. Логично же, да?



----------
Инструкция по выживанию для баранов, пингвинов и пр., в зимнее время

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 18:19 02-02-2012
zveroyacher



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Посоветуйте плагин для работы с печеньками. Что бы значит сайт думал что он оставил печеньки, а я эти печеньки нихрена не жрал пока не посмотрю чего он там хочет сохранить.
 
Заранее спасибо.

Всего записей: 807 | Зарегистр. 03-04-2011 | Отправлено: 18:25 02-02-2012
dmitrydvk

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Кто знает, какие есть аналоги этого дополнения?

Всего записей: 181 | Зарегистр. 22-08-2006 | Отправлено: 19:42 02-02-2012
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka
18:19 02-02-2012
Цитата:
 Как то так

Я там не увидел ни единого упоминания о том, что у того юзера нет старых или проблемных расширений. У большинства я думаю таковых не имеется, потому и бубны не нужны, поскольку выставлены по умолчанию.
 
Но зато я прочел там, что обычная 10-ка и 10-ка ESR - это, оказывается, совсем разные дистрибутивы. Вот этого не знал.

Всего записей: 25547 | Зарегистр. 03-05-2004 | Отправлено: 20:01 02-02-2012 | Исправлено: WatsonRus, 20:05 02-02-2012
klaus65



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
dmitrydvk (19:42 02-02-2012)
Цитата:
Кто знает, какие есть аналоги

Так оно же вроде после правки install.rdf нормально работает в FF10?
 

Всего записей: 1162 | Зарегистр. 16-01-2009 | Отправлено: 20:03 02-02-2012
dmitrydvk

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
klaus65
Да я его правлю, начиная с 4-ки, думаю, может что по-современнее придумали.

Всего записей: 181 | Зарегистр. 22-08-2006 | Отправлено: 20:30 02-02-2012
klaus65



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
dmitrydvk
Вы вон из каких соображений. Тогда посмотрите на ContextMenuPlus

Всего записей: 1162 | Зарегистр. 16-01-2009 | Отправлено: 20:37 02-02-2012
noangst

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
dmitrydvk
Или SelectionSK

Всего записей: 66 | Зарегистр. 18-10-2009 | Отправлено: 22:14 02-02-2012
vkramnik



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
del

Всего записей: 1841 | Зарегистр. 14-12-2005 | Отправлено: 22:16 02-02-2012 | Исправлено: vkramnik, 22:16 02-02-2012
   

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302

Компьютерный форум Ru.Board » Компьютеры » Программы » Расширения для Firefox (Mozilla Firefox Extensions) часть 6
articlebot (15-10-2014 12:58): Переезжаем в следующую часть:
Расширения для Firefox (Mozilla Firefox Extensions) часть 7.


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru