Перейти из форума на сайт.


Система IP-видеонаблюдения "Линия". Скачать бесплатную демо-версию для 16 камер. НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » В помощь системному администратору » MikroTik RouterOS (часть 4)

Модерирует : lynx, Crash_Master, dg, emx, ShriEkeR

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130

Открыть новую тему     Написать ответ в эту тему

evgeniy7676



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
 
MikroTik RouterOS (часть 1), MikroTik RouterOS (часть 2), MikroTik RouterOS (часть 3), MikroTik RouterOS (часть 4)
Официальный сайт: http://www.mikrotik.com
 
Данная тема создана для обмена информацией по вопросам и проблемам настройки MikroTik RouterOS
Тема в варезнике
 
 
актуальные версии RouterOS: 6.40.1, 5.26, 4.17
актуальные версии SwitchOS: 1.17
актуальные версии WinBox: 3.11, 2.2.18

 
Mikrotik — Плюсы и минусы Подробнее...
Видео-экскурсия по заводу Mikrotik Ltd


FAQ по особенностям и тонкостям MikroTik RouterOS  Перейти



Официальная документация:
  • Англоязычный ОФИЦИАЛЬНЫЙ мануал
  • Алфавитный указатель
  • Официальные статьи пользователей RouterOS
  • для версии 3 http://www.mikrotik.com/testdocs/ros/3.0/
  • для версии 2.9 http://www.mikrotik.com/docs/ros/2.9/
  • RouterOS Packet Flow: http://wiki.mikrotik.com/wiki/Packet_Flow (важно знать для понимания сути происходящего в файрволе и шейпере)
  • Совместимое оборудование
  • Описание изменений в новых версиях RouterOS(+rc)
  • RouterBOOT changelog (изменения в boot-версиях загрузчика RouterOS)
  • Система управления пользователями встроенная в RouterOS (RADIUS server)
  • l7-protos.rsc (примеры L7-filter)


    Официальные ресурсы:
    Форум
    Демо-сайт с веб-интерфейсом системы №1        Подробнее...
    Демо-сайт с веб-интерфейсом системы №2        Подробнее...
    MikroTik User Meeting(Конференции пользователей Mikrotik)        Подробнее...
    "Хардварные решения"
    MikroTik News
    MikroTik related video service
    DESIGNS.MIKROTIK.COM - сервис для брендирования продукции Mikrotik.
    Twitter Mikrotik
    MikroTik Training (Хочешь на тренинг? Получить сертификат?)
    Предыдущие версии RouterOS Подробнее...    История релизов  Подробнее...
    Mikrotik Wireless Link Calculator


    Неофициальная русскоязычная документация    Перейти
    Обсуждение ROS(форумы)    Перейти
    Обзоры продуктов RouterBOARD    Перейти


    Русскоязычные блоги интернет-магазинов и блоггеров по настройке и тонкостям Mikrotik:  
     


     

     

     
       


     

     
         
     
     
         
     
     
         
     
     
     



    Смежные ресурсы    Перейти
     
    VPN + OSPF в картинках.
    MikroTik Config Parser
    mikrotik.vetriks.ru

    // текущий бэкап шапки..

  • Всего записей: 120 | Зарегистр. 19-03-2009 | Отправлено: 16:55 30-03-2016 | Исправлено: ans72, 17:30 22-08-2017
    KurskFORUM

    Newbie
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
    Как можно реализовать функционал u32 в RouterOS?
    В iptables есть модуль u32, который берет 4 байта, начиная с заданного смещения (Start), применяет маску (Mask) и сравнивает с результатом (Result). "Start&Mask=Result".
    Есть ли в RouterOS какой-либо способ реализации такой задачи?
    iptables -t raw -A PREROUTING -p tcp --sport 443 -m u32 --u32 "0x4=0x00010000 && 0x20&0xFFFF0000=0x50040000" -j DROP

    Всего записей: 15 | Зарегистр. 15-04-2009 | Отправлено: 00:19 03-10-2017
    leshiy_odessa



    Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
    HUB107

    Цитата:
    Тупой вопрос, но. Как скриптом послать с одного микротика команду на выполнение другому микротику?

    http://wiki.mikrotik.com/wiki/Manual:Tools/Fetch
     
    А на том конце, срипт проверяющий каждую минуты наличие файла.  
    P.S. В теории, на практике такое не проверялось.
     
    KurskFORUM

    Цитата:
    Есть ли в RouterOS какой-либо способ реализации такой задачи?  

    http://wiki.mikrotik.com/wiki/Manual:Scripting
    http://wiki.mikrotik.com/wiki/Manual:Scripting-examples

    Всего записей: 380 | Зарегистр. 23-09-2001 | Отправлено: 13:01 03-10-2017 | Исправлено: leshiy_odessa, 13:01 03-10-2017
    karavan



    Advanced Member
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    KurskFORUM
    К тому, что сказал leshiy_odessa, можно еще API добавить.

    Всего записей: 1174 | Зарегистр. 02-12-2011 | Отправлено: 13:43 03-10-2017
    Chupaka



    Silver Member
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору

    Цитата:
    Как скриптом послать с одного микротика команду на выполнение другому микротику?

    Дополню комментарий leshiy_odessa:
    1) если файл назвать *.auto.rsc - то он должен выполниться автоматически после заливки;
    2) создать его можно не менее костыльным способом:

    Код:
    /interface traffic-eng export file=test.auto.rsc
    /file set test.auto.rsc contents="/log info \"Hello, world!\""
     

    При этом надо следить, чтобы размер export'а в первой части не превысил 4 килобайта - иначе вторая часть не сработает

    Всего записей: 3144 | Зарегистр. 05-05-2006 | Отправлено: 13:55 03-10-2017
    HUB107



    Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

    Цитата:
    HUB107  
     
    Цитата:
    Тупой вопрос, но. Как скриптом послать с одного микротика команду на выполнение другому микротику?
     
    http://wiki.mikrotik.com/wiki/Manual:Tools/Fetch  
     
    А на том конце, срипт проверяющий каждую минуты наличие файла.  
    P.S. В теории, на практике такое не проверялось

    Вопрос совсем о другом. Требуется чтоб один микротик другому средстаами телнет, ssh или чего еще удалённо посылал команды без участия пользователя.

    Всего записей: 297 | Зарегистр. 15-02-2005 | Отправлено: 22:16 03-10-2017
    leshiy_odessa



    Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
    HUB107

    Цитата:
    без участия пользователя.

    В смысле? Микротик еще не обзавелся искусственным интеллектом, чтобы самостоятельно отсылать команды своим собратьям "по разуму".
     
    Вам же ответили, пишете скрипт и они начнут между собой общаться.
     

    Цитата:
    Вопрос совсем о другом.

    У нас видимо тоже интеллекта не хватает, чтобы прочесть ваши мысли. Возможно вы потратите немного усилий и сформулируете ваши вопросы менее пространно.
     

    Цитата:
    средстаами телнет, ssh

    https://wiki.mikrotik.com/wiki/Manual:System/SSH_client
    Но это не будет работать из скрипта или планировщика, только руками.

    Всего записей: 380 | Зарегистр. 23-09-2001 | Отправлено: 22:47 03-10-2017 | Исправлено: leshiy_odessa, 22:48 03-10-2017
    Chupaka



    Silver Member
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    HUB107

    Цитата:
    Вопрос совсем о другом

    Вот о другом я и написал, вроде как

    Всего записей: 3144 | Зарегистр. 05-05-2006 | Отправлено: 08:36 04-10-2017
    HUB107



    Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

    Цитата:
    В смысле?  

    На 120-ой странице же писал "Как скриптом послать с одного микротика команду на выполнение другому микротику?" На 121-ой писал "другому средствами телнет, ssh или чего еще".
     
    Режим файликов простите но это изврат. Просто нужен скрипт с отсылкой команд скриптом из планировщика с одного микротика на другой.

    Всего записей: 297 | Зарегистр. 15-02-2005 | Отправлено: 09:08 04-10-2017
    Chupaka



    Silver Member
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    HUB107

    Цитата:
    Просто нужен скрипт с отсылкой команд скриптом из планировщика с одного микротика на другой.

    Тогда ответ лаконичен и прост: такой возможности нет.

    Всего записей: 3144 | Зарегистр. 05-05-2006 | Отправлено: 09:13 04-10-2017
    Crazy Cooler



    Newbie
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    Всем привет! А кто сталкивался с такой задачкой:
    Дано: Роутер микротик
    WAN X.X.X.X
    LAN 192.168.0.0/24
     
    заNATить (зазеркалить) пакет, например, прилетающий на WAN порт 7772 и отправить его на LAN 192.168.0.2 и 192.168.0.3  порт 3311 ?
    Если создать 2 правила, сработает верхнее, при условии, что оба хоста в локальной сети работают постоянно... Решения пока не нашел. Скрипт переключения правил по условию недоступности одного из внутренних хостов - не предлагать(((

    Всего записей: 21 | Зарегистр. 02-10-2007 | Отправлено: 13:48 04-10-2017
    vlh

    Advanced Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

    Цитата:
    Crazy Cooler
    192.168.0.2 и 192.168.0.3

     
    Можно сделать адрес-лист для этих двух ip и пере-направлять пакет не на ip, а на адрес-лист. Только как Вы себе представляете эту работу?

    Всего записей: 748 | Зарегистр. 21-11-2009 | Отправлено: 14:05 04-10-2017
    Crazy Cooler



    Newbie
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    vlh
    в принципе должно работать, т.к. там будет проброс udp трафика  
     
    Добавлено:
    vlh
    к сожалению в dst-nat нет возможности указать адрес лист... только ip

    Всего записей: 21 | Зарегистр. 02-10-2007 | Отправлено: 14:15 04-10-2017
    HUB107



    Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

    Цитата:
    в принципе должно работать, т.к. там будет проброс udp трафика  

    ну udp порт отдельно походу фиг, но можно физический порт 1 в 1 средствами Port Mirroring походу

    Всего записей: 297 | Зарегистр. 15-02-2005 | Отправлено: 14:31 04-10-2017
    Crazy Cooler



    Newbie
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    HUB107
    все дело в том, что хосты в локальной сети воткнуты в свич за роутером, а не на прямую в микротик (который вроде как имеет вариант зеркалирования портов)

    Всего записей: 21 | Зарегистр. 02-10-2007 | Отправлено: 14:34 04-10-2017
    karavan



    Advanced Member
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    HUB107

    Цитата:
    Режим файликов простите но это изврат

    Изврат - это когда с одного микрота пытаться управлять другим микротом пересылкой команд.
    Естественно, что любое предложение по решению твоей задачи будет в рамках обозначенного тобой изврата.
    Можешь себя обвинить в извращениях.

    Всего записей: 1174 | Зарегистр. 02-12-2011 | Отправлено: 14:35 04-10-2017
    flash_83

    Junior Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
    Доброго дня!
    С микротиком раньше дела не имел, говорю сразу, возникла задача - поднять vpn pptp сервер на CRS125 + yota-свисток и открыть к нему доступ, что было сделано:
    /ppp profile
    add change-tcp-mss=yes local-address=vpn_pool name=vpn remote-address=\
        vpn_pool use-ipv6=no
    /interface pptp-server server
    set enabled=yes
    /ip cloud
    set ddns-enabled=yes
    /ip dhcp-client
    add default-route-distance=2 dhcp-options=hostname,clientid disabled=no \
        interface=lte1
    /ip firewall filter
    add action=accept chain=input protocol=icmp
    add action=accept chain=forward log=yes protocol=icmp
    add action=accept chain=input connection-state=established
    add action=accept chain=forward connection-state=established
    add action=accept chain=input connection-state=related
    add action=accept chain=forward connection-state=related
    /ip firewall nat
    add action=masquerade chain=srcnat out-interface=lte1
    add action=dst-nat chain=dstnat dst-port=1723 log=yes protocol=tcp \
        to-addresses=10.0.0.10 to-ports=1723
    В шедулере стоит скрипт, который каждые 5 минут проверяет внешний ip адрес для Cloud. Из внутренней сети подключаюсь без проблем, со внешки - ничего (ошибка 807), пинги тоже не ходят... Что не так?

    Всего записей: 194 | Зарегистр. 24-01-2007 | Отправлено: 13:57 06-10-2017
    online365



    Junior Member
    Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
    Ребята прошу помощи в настройке Mikrotik rb2011uias
     
    1 Нужно чтобы network 1 не видела устройств за модемом/роутером. От network 1 в сеть проходит только интернет!  
     
    2. зеленая и красная сети не связаны (из любой сети в прямоугольнике другую/параллельную сеть увидеть нельзя - сканерами портов или IP или еще чем)  
     
    3. PC1 и PC2 имеют доступ к NAS хранилищу.  
     
    Я пробовал по юзерски разделить network 1 и Интернет 1 разными роутерами, но так как их связывает NAS сети видно!  
     

     
     
    Спасибо

    Всего записей: 51 | Зарегистр. 01-09-2009 | Отправлено: 17:17 06-10-2017
    lublupospat44

    Newbie
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
    При очередном обновлении программного, одно и з устройств не загрузилось.  
    Устройство не определилось по IP,  MAC, RoMON  
    После этого была предпринята попытка сбросить его до заводских параметров (безрезультатно).  
    Устройство судя по светодиодам корректно реагировало на подключение сетевого кабеля, удерживание кнопки сброса.  
    Но так и не появилось WInBOX, и NetInstall  
    Так как в наличие есть еще около 20 таких-же устройств, то для проверки была снята Firmware c Flash другого такого-же устройства.  
    После чего роутер благополучно загрузился, но появились проблемы с лицензией и поменялся серийный номер устройства.  
     
    От офф поддержки получил  
    Without properly repairing device in our services you can not simply move flash from one device to another and use device without any issues.  
    However if warranty over, then seller will not accept device for such repairs.  
     
    Может у кого есть идеи как вернуть его к жизни

    Всего записей: 7 | Зарегистр. 01-05-2011 | Отправлено: 14:28 07-10-2017
    leshiy_odessa



    Member
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
    lublupospat44

    Цитата:
     Может у кого есть идеи как вернуть его к жизни  

     
    Прошить в OpenWRT и забить на лицензию.

    Всего записей: 380 | Зарегистр. 23-09-2001 | Отправлено: 15:12 07-10-2017
    lublupospat44

    Newbie
    Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

    Цитата:
    Прошить в OpenWRT и забить на лицензию.

    Мы не ищем легких путей и нет еще на него стабильной OpenWRT  
    is the first mikrotik's board for which supports squashfs+jffs2 and sysupgrade (through shell or LuCI). No more crutches with yaffs!

    Всего записей: 7 | Зарегистр. 01-05-2011 | Отправлено: 15:20 07-10-2017
    Открыть новую тему     Написать ответ в эту тему

    Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130

    Компьютерный форум Ru.Board » Компьютеры » В помощь системному администратору » MikroTik RouterOS (часть 4)

    Имя:
    Пароль:
    Сообщение

    Для вставки имени, кликните на нем.

    Опции сообщенияДобавить свою подпись
    Подписаться на получение ответов по e-mail
    Добавить тему в личные закладки
    Разрешить смайлики?
    Запретить коды


    Реклама на форуме Ru.Board.

    Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
    Modified by Ru.Board
    © Ru.Board 2000-2017

    BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

    Рейтинг.ru