Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » В помощь системному администратору » FAQ по Exim MTA

Модерирует : lynx, Crash_Master, dg, emx, ShriEkeR

ShriEkeR (16-05-2011 18:50): FAQ по Exim MTA #2  Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102

   

ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Текущая версия Exim 4.72

   Home page Автор Philip Hazel, University of Cambridge.
Exim - чертовски быстр, отличный выбор для загруженных систем. Свободно распространяемый Mail Transport Agent (MTA, лицензия GPL), обладающий возможностью очень гибкой и тонкой настройки, включая поиск конфигурационной информации в базах данных - mySQL, PostgresQL, Oracle, SQLite.., а также LDAP.  В Exim встроена поддержка Maildir (quota), SMTP-аутентификация, TLS/SSL, SpamAssassin, сканирование на лету антивирусом(ами), ACL, системные фильтры... Сомневающимся.
На многие вопросы помогут найти ответы рассылки: На русском + На английском
Документация на русском по Exim + много полезной инфы на www.lissyara.su

Установка почтового сервера на базе Exim с поддержкой виртуальный аккаунтов (MySQL).
Подробное руководство состоит из двух связанных частей:
   1. Установка и настройка Exim 4.20.
   2. Установка  и настройка Tpop3d с поддержкой виртуальных аккаунтов.
Внимательно читаем здесь © ginger
-=-=-=-
Улучшенный вариант части 1: Exim-4.50 + MySQL © ginger
-=-=-=-
Так как Tpop3d не совместим с MS Outlook Express 6, а также не поддерживает IMAP, автор рекомендует его заменить на Dovecot. Изменения, которые нужно сделать cмотрим здесь © ginger
-=-=-=-
Еще один вариант установки © Wombat
-=-=-=-
Exim+Courier-Imap+MySQL+ClamAV+DSPAM+SquirrelMail © Павел Семенец Искать по ctrl+F=Павел Семенец
-=-=-=-
Опции для сборки exim из портов (FreeBSD) © tankistua
 
Уважаемые коллеги!
 
Нам очень дороги ваши конфиги и логи на несколько страниц, но, поверьте, их гораздо приятнее читать когда они заключены в тэг more.

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 10:58 29-08-2003 | Исправлено: hoochie, 22:55 16-12-2010
Markes



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Pleshkov

Цитата:
В логах что нибудь по этому поводу есть?
Ничего нет.

Всего записей: 1403 | Зарегистр. 13-09-2004 | Отправлено: 12:00 16-06-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Markes
Так же я хочу обратиться ко всем остальным, прежде чем постить подобные вопросы не поленитесь зайти например на http://www.google.com и ввести нужный Вам запрос, в случае если Вы не нашли ответа, то можно обращаться сюда.
 
http://www.google.ru/search?biw=1004&hl=ru&q=exim+vacation&lr=

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 14:50 19-06-2005
hfnclkju



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Привет!  
Прочел статью твою.  
Возникли проблеммы в том, что:
Дело до сборки.
 
распоковал все в /scr/exim-x.x.x
поправил файл Local/Makefile
 
--->
make
--->
cd /
find /* >exim1  
 
следующее что делаю это инсталирую собранные пакеты.
make install
------------------
тут то и загвозка, но дело в здобрке и устанвке, а в том, что файлов exim* та в /usr/sbin нет.
------------------------
ls /usr/sbin/ex*
/usr/sbin/extattrctl
------------------------
 
оставился на ссылках. как быть?  
 
 
 
 
 
Добавлено:
.
 
Мдя.
Как это может быть?  
 
mail# exim -bV
/libexec/ld-elf.so.1: Shared object "libmysqlclient.so.14" not found, required by "exim"

Всего записей: 1 | Зарегистр. 18-07-2005 | Отправлено: 13:00 18-07-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
hfnclkju
После команды make install выполните
cd
find /* >exim2
diff exim1 exim2 > exim-files
После этого заглянув в exim-files, можно будет увидеть куда была произведена установка... Затем сделать соответсвующие поправки в файле Local/Makefile
Так же желательно увидеть Ваш Local/Makefile.

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 10:35 19-07-2005
loukash

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Такая вот у меня ошибка.
 
/usr/local/exim/bin/exim -bt user@pochta.domain.ru
LOG: MAIN
  lowest numbered MX record points to local host: pochta.domain.ru (while routing <user@pochta.domain.ru>)
user@pochta.domain.ru cannot be resolved at this time:
  lowest numbered MX record points to local host
 
Виртуальный домен pochta.domain.ru в базе мускула есть (но директория в /home/vmail не появилась). Помогите решить проблему

Всего записей: 3 | Зарегистр. 20-07-2005 | Отправлено: 11:53 20-07-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
loukash
Каталог /home/vmail нужно создать вручную, установив при этом права доступа 770 для соответствующего пользователя, в моем случае это mail.mail.
Попробуйте выполнить команду exim -d -bt user@pochta.domain.ru для большего анализа происходящего...
Как правило сия ошибка возникает когда домен не прописан в local_domains...

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 22:04 20-07-2005
SEMENYCH



Junior Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Доброго времени суток!!!
такая проблема: вся почта сваливается у хостера (Exim 4.43), у которого открытый релей. Кто-то этим пользуется и рассылает спам от доменного имени нашей конторы. Хостер говорит что закрыть релей он не может, т.к. на почтовом серваке крутится много виртуальных почтовиков других клиентов, у которых из-за этого будут проблемы. Можно ли в этом (Exim 4.43) прикрутить SMTP AUTH для отдельного аккаунта, либо сделать еще что нибудь чтобы закрыть этот спам, который мы не рассылаем???

Всего записей: 120 | Зарегистр. 28-01-2002 | Отправлено: 11:00 25-07-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
SEMENYCH
Такой ответ не достоен уважающей себя компании, поэтому мои рекомендации отказаться от услуг этого хостера! Так же рекомендую вам потребовать компенсацию за бездействие вашего хостера в сложившейся ситуации.
Авторизацию можно сделать для какой либо подсети или IP-адреса, так же рекомендую прописать в записях вашего сервера имен spf запись, где указать с какого IP-адреса или сети разрешено рассылать почту вашего домена.

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 09:21 26-07-2005
BigHarry



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Приветствую вас господа !
Хотел установить новый Exim (4.52) на FreeBSD 4.10, но там переписали поддержку SPF под libspf2 ver.2, а эта libspf2 ver.2.0.5 не собирается под FreeBSD 4.10 !
Без функционала SPF Exim прекрасно компилируется, но SPF-то нужна! Переустанавливать фрюху на пятерку не могу - слишком много всякого настроенного софта там работает. Что можно сделать?

Всего записей: 75 | Зарегистр. 05-02-2003 | Отправлено: 19:21 26-07-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
BigHarry
libspf2 ver.2.0.5 - такой версии не существует, текущая 1.2.5.
Если 1.2.5 не собирается по какой либо причине, что вам мешает использовать, например 1.2.4?

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 09:57 27-07-2005
BigHarry



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ginger
Да, я ошибся - конечно-же 1.2.5
Версия 1.2.2, 1.2.3 и 1.2.4 тоже не собираются - очевидно - афтар libspf2 что-то там переиначил, что под FreeBSD 4.х эти версии вааще не собираются, после часового гемороя с латанием всевозможных ерроров компиляции - вываливается такая ошибка:

Цитата:
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_getspecific'
../../src/libspf2/.libs/libspf2.so: undefined reference to `res_ninit'
../../src/libspf2/.libs/libspf2.so: undefined reference to `res_nclose'
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_once'
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_key_create'
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_unlock'
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_destroy'
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_lock'
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_init'
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_setspecific'
 

Версия libspf2, которая собирается на четверке - это 1.0.4, но новый Exim отказывается собираться с такой либой. Приехали, называется. Только недавно избавись от необходимости накладывать патч на сырцы экзима для SPF и прочих прелестей - и опять придется ждать героя, который наложит патч на libspf2

Всего записей: 75 | Зарегистр. 05-02-2003 | Отправлено: 11:06 27-07-2005
tankistua

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
BigHarry
скомпиль без SPF .
 
Ну подумаешь чуть больше спама тебе падать будет :)
 
Думаю что ситуация в скором времени починится

Всего записей: 9572 | Зарегистр. 15-01-2002 | Отправлено: 11:23 27-07-2005
BigHarry



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
tankistua
Фигасе, чуть меньше - rambler.ru, yandex.ru - просто дофига гавнюков, которые рассылают якобы от этих доменов!

Всего записей: 75 | Зарегистр. 05-02-2003 | Отправлено: 11:38 27-07-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Попрошу не отклоняться от темы!
 
BigHarry
Во FreeBSD используются порты если мне не изменяет память, наверняка уже имеются обновленные версии Exim/SPF для сборки этих программ.
Еще один вариант это использовать perl-модуль, информацию о котором можной найти на http://www.libsrs2.org/status.html

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 11:55 27-07-2005
BigHarry



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ginger
В портах для FreeBSD 4.11 есть только libspf2 1.0.4, для пятой Бзди -  1.2.5
А перловый модуль - тот что для постфикса? Он вроде использует демон spfd (который опять-таки не собирается), да и сомнительно, что это к Экзиму прикрутиться...
 
Добавлено:
ginger
В портах для FreeBSD 4.11 есть только libspf2 1.0.4, для пятой Бзди -  1.2.5
А перловый модуль - тот что для постфикса? Он вроде использует демон spfd (который опять-таки не собирается), да и сомнительно, что это к Экзиму прикрутиться...

Всего записей: 75 | Зарегистр. 05-02-2003 | Отправлено: 12:21 27-07-2005
tankistua

Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
вопрос на засыпку:
 
а где в портах 4.52 екзим ? в портах последняя версия - 4.51

Всего записей: 9572 | Зарегистр. 15-01-2002 | Отправлено: 12:50 27-07-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
BigHarry
Попробуйте задать сей вопрос пользователям FreeBSD. Возможно в вашем дистрибутиве не хватает каких-то дополнительных библиотек и файлов для сборки Exim/libspf2/spfd.

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 13:15 27-07-2005
BigHarry



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
tankistua
Я Exim из сырцов собираю, в портах он очевидно не сразу появляется.
ginger
Нет, дело похоже все-таки в том, что libspf2 нужна именно пятая бзд. Ведь если не хватает каких-то файлов - то компилятор прямо так и говорит, а тут - ndefined reference to `pthread_mutex_destroy' - очевидно ядро немного другое.
Что-ж - остается только ждать, когда куча народа наступит на эти грабли (ведь четверку есчо рано списывать в отстой) и разшевелит либо автора Экзима либо автора spf.
Жалко, что по-ангийски я не пишу, так можно было бы задать вопрос в Exim-dev:  exim-dev@exim.org

Всего записей: 75 | Зарегистр. 05-02-2003 | Отправлено: 14:29 27-07-2005
ginger



Рыжик
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
BigHarry
Если при сборке возникает ошибка вида:

Цитата:
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_getspecific'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `res_ninit'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `res_nclose'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_once'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_key_create'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_unlock'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_destroy'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_lock'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_mutex_init'  
../../src/libspf2/.libs/libspf2.so: undefined reference to `pthread_setspecific'

То попробуйте добавить ключ "-lpthread" в строку LOOKUP_LIBS, в итоге должно получиться что-то вроде: LOOKUP_LIBS=-L/usr/local/lib/mysql -lmysqlclient -lz -lcrypt -lm -lpthread

----------
Кто людям помогает, тот тратит время зря... Хорошими делами прославиться нельзя...

Всего записей: 852 | Зарегистр. 03-09-2001 | Отправлено: 15:55 27-07-2005
BigHarry



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ginger
Эти ошибки появляются не при сборке Exim-a, а при сборке libspf2.
При компилеже Exim-а другие ошибки, и связаны они с отсутствием libspf2...

Всего записей: 75 | Зарегистр. 05-02-2003 | Отправлено: 17:23 27-07-2005
   

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102

Компьютерный форум Ru.Board » Компьютеры » В помощь системному администратору » FAQ по Exim MTA
ShriEkeR (16-05-2011 18:50): FAQ по Exim MTA #2


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru