Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Модерирует : ShIvADeSt

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560

Открыть новую тему     Написать ответ в эту тему

ShIvADeSt



Moderator
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Тема для программирования 1С!!!
Это продолжение темы, предыдущие части доступны тут


 Программы » 1С:Предприятие 1C - 1C: Вопросы по конфигурациям

 Варезник » 1C:Предприятие 7.7 - 1С:Предприятие v.8.x - 1C Диск ИТС - 1С: Совместимо 8.х
Топик 1C Ebooks
ЗДЕСЬ  (обновлено 22.02.14) - небольшая библиотечка (книги, документация, видео, утилиты) по 1С, финансам, бухучету и т.п.
Все рассортировано по версиям...
Для заблудившихся в трех соснах >>> FAQ по форуму RU.Board
 
Предыдущие темы были здесь часть 5 | часть 4 | часть 3 | часть 2 | часть 1
 
Как убить рекламу при обновлении отчетности | конфигурации (ИБ)?

Всего записей: 3952 | Зарегистр. 29-07-2003 | Отправлено: 09:50 30-10-2009 | Исправлено: M_Volkov, 11:12 14-01-2020
M_Volkov



Gold Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Vizor2294

Цитата:
Я так понял, что лучше и надежнее всё ручками перенести, благо база не очень большая

Ну если решили сразу "жечь мосты". Бывает общую базу используют как управленческую, а из нее постоянно выгружают в "белые-пушистые" официальные базы. Тогда ни каких ручек шалавливых...

Всего записей: 5011 | Зарегистр. 23-06-2008 | Отправлено: 04:20 09-11-2015
Vizor2294

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
M_Volkov
 
Нет, здесь другая ситуация... кстати удалось "накурить" в инете обработку, которая с легкостью справилась с этой задачей.
Всем спасибо.

Всего записей: 36 | Зарегистр. 13-10-2012 | Отправлено: 09:35 09-11-2015
Templl

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Vizor2294
Что за обработка можешь ссылку скинуть?

Всего записей: 144 | Зарегистр. 26-06-2011 | Отправлено: 09:53 09-11-2015
HePapyc

Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Templl
Что за обработка можешь ссылку скинуть?

Скорее всего типовая Выгрузка-загрузка между идентичными конфигурациями, допиленная на отбор по организации.

Всего записей: 718 | Зарегистр. 25-02-2009 | Отправлено: 20:09 09-11-2015
RusNaM

Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Добрый вечер!
 
Подскажите пожалуйста как сделать правильно апгрейд ЗУП 3.0 базовую на ПРОФ. Чтобы после апгрейда в начисления можно было сделать по подразделениям как ЗУПе 3.0 ПРОФ. В базовой этой возможности нет, после апгрейда тоже не появляется. Или я не так делаю. Обновляю с версии переход с базовой на ПРОФ.
 
Заранее ОГРОМНОЕ СПАСИБО за помощь.

Всего записей: 83 | Зарегистр. 23-06-2010 | Отправлено: 15:42 13-11-2015
opt_step



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
комплексная 7.7

Код:
Перем КолвоУпак;
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =  
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Реализация = Документ.Реализация.ТекущийДокумент;
    |Контрагент = Документ.Реализация.Контрагент;
    |Номенклатура = Документ.Реализация.Номенклатура;
    |Количество = Документ.Реализация.Количество;
    |Функция КоличествоСумма = Сумма(Количество);
    |Группировка Контрагент без групп упорядочить по Контрагент.Наименование;
    |Группировка Реализация;
    |Условие(Контрагент в ВыбКонтрагент);
    |Условие(Номенклатура в ВыбНоменклатура);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
 
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей Контрагент
        Таб.ВывестиСекцию("Контрагент");  
        КолвоУпак = Запрос.Количество/Запрос.Номенклатура.Фасовка;
        Если Подробно = 1 Тогда
            Пока Запрос.Группировка(2) = 1 Цикл
                // Заполнение полей Реализация
                Таб.ВывестиСекцию("Реализация");
                
            КонецЦикла;
        КонецЕсли;
    КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры

http://rghost.ru/8x6vFDQbn
значение желтой ячейки = КолвоУпакСумма#N019.0
но итого не считает, помогите

----------
Reset - не кнопка, а горькая необходимость.

Всего записей: 11181 | Зарегистр. 10-09-2008 | Отправлено: 11:19 16-11-2015 | Исправлено: opt_step, 11:20 16-11-2015
M_Volkov



Gold Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
УФ форме списка с отбором и группировкой делается сортировка:
Код:
&НаСервере
Процедура УстановитьОтборПоИнициаторам()
    
    ИнициаторФизЛицо = ИнициаторФизЛицо();
    СписокПодчиненныхСотрудников = СписокПодчиненныхСотрудников();
    Если Не ИнициаторФизЛицо.Пустая() И СписокПодчиненныхСотрудников.НайтиПоЗначению(ИнициаторФизЛицо) = Неопределено Тогда
        СписокПодчиненныхСотрудников.Добавить(ИнициаторФизЛицо);
    КонецЕсли;
                        
    Если СписокПодчиненныхСотрудников.Количество() > 0 Тогда  
            
        ПараметрОтбор = Список.Отбор.Элементы.Добавить(Тип("ЭлементОтбораКомпоновкиДанных"));
        ПараметрОтбор.ЛевоеЗначение    = Новый ПолеКомпоновкиДанных("Инициатор");
        ПараметрОтбор.ВидСравнения       = ВидСравненияКомпоновкиДанных.ВСписке;
        ПараметрОтбор.Использование       = Истина;  
        ПараметрОтбор.РежимОтображения = РежимОтображенияЭлементаНастройкиКомпоновкиДанных.Недоступный;
        ПараметрОтбор.ПравоеЗначение   = СписокПодчиненныхСотрудников;
        
        ПолеГруппировки = Список.Группировка.Элементы.Добавить(Тип("ПолеГруппировкиКомпоновкиДанных"));
        ПолеГруппировки.Поле = Новый ПолеКомпоновкиДанных("Инициатор");
            
    УсловиеСортировки = Список.Порядок.Элементы.Добавить(Тип("ЭлементПорядкаКомпоновкиДанных"));
    УсловиеСортировки.Поле = Новый ПолеКомпоновкиДанных("Номер");
    УсловиеСортировки.ТипУпорядочивания = НаправлениеСортировкиКомпоновкиДанных.Убыв;
            
    КонецЕсли;
        
КонецПроцедуры

Хотелось, чтобы при открытии формы все группировки были свернуты кроме группировки руководителя. Такое (пожелание пользователя) возможно?

Всего записей: 5011 | Зарегистр. 23-06-2008 | Отправлено: 19:36 16-11-2015 | Исправлено: M_Volkov, 06:07 17-11-2015
steptostep

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору

Цитата:
Код:
Перем КолвоУпак;
Процедура Сформировать()
    Перем Запрос, ТекстЗапроса, Таб;
    //Создание объекта типа Запрос
    Запрос = СоздатьОбъект("Запрос");
    ТекстЗапроса =  
    "//{{ЗАПРОС(Сформировать)
    |Период с ВыбНачПериода по ВыбКонПериода;
    |Реализация = Документ.Реализация.ТекущийДокумент;
    |Контрагент = Документ.Реализация.Контрагент;
    |Номенклатура = Документ.Реализация.Номенклатура;
    |Количество = Документ.Реализация.Количество;
    |Функция КоличествоСумма = Сумма(Количество);
    |Группировка Контрагент без групп упорядочить по Контрагент.Наименование;
    |Группировка Реализация;
    |Условие(Контрагент в ВыбКонтрагент);
    |Условие(Номенклатура в ВыбНоменклатура);
    |"//}}ЗАПРОС
    ;
    // Если ошибка в запросе, то выход из процедуры
    Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
        Возврат;
    КонецЕсли;
 
    // Подготовка к заполнению выходных форм данными запроса
    Таб = СоздатьОбъект("Таблица");
    Таб.ИсходнаяТаблица("Сформировать");
    // Заполнение полей "Заголовок"
    Таб.ВывестиСекцию("Заголовок");
    Состояние("Заполнение выходной таблицы...");
    Таб.Опции(0, 0, Таб.ВысотаТаблицы(), 0);
КолвоУпакСумма = 0;
    Пока Запрос.Группировка(1) = 1 Цикл
        // Заполнение полей Контрагент
        Таб.ВывестиСекцию("Контрагент");  
        КолвоУпак = Запрос.Количество/Запрос.Номенклатура.Фасовка;
        Если Подробно = 1 Тогда
            Пока Запрос.Группировка(2) = 1 Цикл
                // Заполнение полей Реализация
                Таб.ВывестиСекцию("Реализация");
                 
            КонецЦикла;
        КонецЕсли;
КолвоУпакСумма = КолвоУпакСумма+КолвоУпак;
   КонецЦикла;
    // Заполнение полей "Итого"
    Таб.ВывестиСекцию("Итого");
    // Вывод заполненной формы
    Таб.ТолькоПросмотр(1);
    Таб.Показать("Сформировать", "");
КонецПроцедуры  

 
как-то так изменить

Всего записей: 17 | Зарегистр. 06-02-2003 | Отправлено: 11:21 17-11-2015
opt_step



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
steptostep
не работает

----------
Reset - не кнопка, а горькая необходимость.

Всего записей: 11181 | Зарегистр. 10-09-2008 | Отправлено: 12:30 17-11-2015
v_abazow



Newbie
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
opt_step
а может вам выгрузить результат запроса в таблицу значений? а уж с ней потом что угодно, и итоги по колонкам в том числе.

Всего записей: 3 | Зарегистр. 10-11-2015 | Отправлено: 07:58 18-11-2015
opt_step



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
v_abazow
помогите, как?

----------
Reset - не кнопка, а горькая необходимость.

Всего записей: 11181 | Зарегистр. 10-09-2008 | Отправлено: 12:37 18-11-2015
makd0c



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подскажите пожалуйста где можно скачать 1C:Enterprise Development Tools, есть ли на дисках ИТС?
 
Добавлено:
Подскажите пожалуйста где можно скачать 1C:Enterprise Development Tools, есть ли на дисках ИТС?

Всего записей: 8 | Зарегистр. 22-04-2015 | Отправлено: 14:53 18-11-2015
v_abazow



Newbie
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Подробнее...

Всего записей: 3 | Зарегистр. 10-11-2015 | Отправлено: 20:54 18-11-2015 | Исправлено: v_abazow, 20:58 18-11-2015
andreymik

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Существует ли у кого-нибудь отчёт по продажам для 1С:Бухгалтерия 7.7?

Всего записей: 14 | Зарегистр. 12-01-2010 | Отправлено: 03:13 19-11-2015
opt_step



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
andreymik

Цитата:
Существует ли у кого-нибудь отчёт по продажам для 1С:Бухгалтерия 7.7?

а родной чем не устраивает ?

----------
Reset - не кнопка, а горькая необходимость.

Всего записей: 11181 | Зарегистр. 10-09-2008 | Отправлено: 07:23 19-11-2015
M_Volkov



Gold Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Подскажите, база УСЦ 1.5 (УНФ) файловая копия. Где в ней отключаются фоновые задания, всякие напоминания (например, о не сделанной резервной копии)?

Всего записей: 5011 | Зарегистр. 23-06-2008 | Отправлено: 08:40 19-11-2015
zzzz5555



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
M_Volkov
Ну если на основе УНФ, вероятно, там же, где и в УНФ, в обработке "Регламентные и фоновые задания".
О сделанной резервной копии, думаю, это не фоновое задание, настраивается в обработке "Настройка резервного копирования ИБ" (я про обработки внутри конфигурации, а не внешние).

Всего записей: 839 | Зарегистр. 26-10-2009 | Отправлено: 19:20 19-11-2015 | Исправлено: zzzz5555, 19:20 19-11-2015
andreymik

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
to opt_step: А он есть?

Всего записей: 14 | Зарегистр. 12-01-2010 | Отправлено: 01:13 20-11-2015 | Исправлено: andreymik, 01:14 20-11-2015
M_Volkov



Gold Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Приветствую всех! Забыл как делается, чтобы по клику мышки в отчете по строке документа открылся сам документ?
Код:
    Для каждого Строка Из Результат Цикл
        Ном = Ном + 1;
        ОбластьМакета = Макет.ПолучитьОбласть("Документ");
        ОбластьМакета.Параметры.Ном = Ном;
        ОбластьМакета.Параметры.Документ = Строка.Документ;
    //    ОбластьМакета.ПараметрРасшифровки.Документ = Строка.Документ;
        ОбластьМакета.Параметры.СуммаДокумента  = Формат(Строка.СуммаДокумента, ФорматВыводаСуммы);
        ОбластьМакета.Параметры.СуммаНачисления = Формат(Строка.СуммаНачисления, ФорматВыводаСуммы);
        ТабДокумент.Вывести(ОбластьМакета);
    КонецЦикла;


Всего записей: 5011 | Зарегистр. 23-06-2008 | Отправлено: 08:16 23-11-2015
ZloyBrawler



Full Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
M_Volkov
В каждую ячейку строки в которой ваш документ, нужно как расшифровку указать ваш документ, ссылку.
И главное, чтобы табличный документ был не в состоянии редактирования, а то ссылки не будут пахать.

Всего записей: 490 | Зарегистр. 19-10-2010 | Отправлено: 08:28 23-11-2015
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199 200 201 202 203 204 205 206 207 208 209 210 211 212 213 214 215 216 217 218 219 220 221 222 223 224 225 226 227 228 229 230 231 232 233 234 235 236 237 238 239 240 241 242 243 244 245 246 247 248 249 250 251 252 253 254 255 256 257 258 259 260 261 262 263 264 265 266 267 268 269 270 271 272 273 274 275 276 277 278 279 280 281 282 283 284 285 286 287 288 289 290 291 292 293 294 295 296 297 298 299 300 301 302 303 304 305 306 307 308 309 310 311 312 313 314 315 316 317 318 319 320 321 322 323 324 325 326 327 328 329 330 331 332 333 334 335 336 337 338 339 340 341 342 343 344 345 346 347 348 349 350 351 352 353 354 355 356 357 358 359 360 361 362 363 364 365 366 367 368 369 370 371 372 373 374 375 376 377 378 379 380 381 382 383 384 385 386 387 388 389 390 391 392 393 394 395 396 397 398 399 400 401 402 403 404 405 406 407 408 409 410 411 412 413 414 415 416 417 418 419 420 421 422 423 424 425 426 427 428 429 430 431 432 433 434 435 436 437 438 439 440 441 442 443 444 445 446 447 448 449 450 451 452 453 454 455 456 457 458 459 460 461 462 463 464 465 466 467 468 469 470 471 472 473 474 475 476 477 478 479 480 481 482 483 484 485 486 487 488 489 490 491 492 493 494 495 496 497 498 499 500 501 502 503 504 505 506 507 508 509 510 511 512 513 514 515 516 517 518 519 520 521 522 523 524 525 526 527 528 529 530 531 532 533 534 535 536 537 538 539 540 541 542 543 544 545 546 547 548 549 550 551 552 553 554 555 556 557 558 559 560

Компьютерный форум Ru.Board » Компьютеры » Прикладное программирование » 1С Программирование и поддержка (1C)

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2020

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru