Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Hardware » Драйверы и прошивки BIOS » Восстановление роутера (TP-Link) через Serial

Модерирует : Akam1, Dr_StandBy, Dekker

 Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26

Открыть новую тему     Написать ответ в эту тему

westmonster

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Купил кабель CA-42, но оказалась китайским под-оригиналом. Чипсет Ark micro.
Впринципе драйвера ставятся. У кого нибудь был опыт восстановления с кабелем с таким чипсетом? И вообще стоит ли с ним связываться или другой кабель лучше искать?
Спасибо!

Всего записей: 1 | Зарегистр. 24-10-2013 | Отправлено: 22:21 24-10-2013
westwild_007



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
прошу помощи,что не так делаю
 
достался  убитый Tl WR 841ND, сетит питание и моргает настройка
при подключении через Путти выдает  
определяется как  board=TL-WR741ND
 
Подробнее...
 
и на етом заканчивается
при вводе tpl вискакивает
OPENWRT  
Подробнее...
попробовал еще раз, tpl. наверно успел ввести
выскочило   ar7240>    
пробую вводить команды, а набираются квадратики
Подробнее...
пробовал лить разные прошивки
при выполнении    tftpboot 0x80000000 op.bin  идет копирование и прерывается и так по кругу
может можно другой какой то адрес задать для копирования вместо 0x80000000 например 0x81000000

Всего записей: 224 | Зарегистр. 28-05-2008 | Отправлено: 15:26 26-10-2013 | Исправлено: westwild_007, 21:28 26-10-2013
westwild_007



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Поднял сегодня "пациента" Tl WR 841ND
оказалось собака зарыта была в Tftpd32 с версией 4,00 глюки были,не шило,по кругу гоняло
поставил Tftpd32  3.51 и с первого раза пошло все
 
Добавлено:
westmonster
лучше на Pl 2303HX   их валом, я взял от самсунга с-100 и никаких заморочек. три проводка припаял и все ,если не считать програмных

Всего записей: 224 | Зарегистр. 28-05-2008 | Отправлено: 22:48 28-10-2013
Glushak

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Подробнее...

Всего записей: 1 | Зарегистр. 01-11-2013 | Отправлено: 05:02 01-11-2013
westwild_007



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Glushak
tpl нужно успеть прописать после Autobooting in 1 seconds  
 
Это ## Booting image at 9f020000 ...  появляться не должно
Скопируйте tpl в буфер и правой кнопкрй мыши щелкайте при загрузке модема
Если успеете то  ## Booting image at 9f020000 ...
   Uncompressing Kernel Image ...  не появится и дальше можно будет вводить команды
 
## Booting image at 9f020000 ... это уже загрузка вашей прошивки из роутера......

Всего записей: 224 | Зарегистр. 28-05-2008 | Отправлено: 21:50 01-11-2013 | Исправлено: westwild_007, 21:51 01-11-2013
HellEvil

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
здравствуйте. роутер 1043nd. Убит при прошиаке на OpenWRT если не ошибаюсь.
подключаюсь к роутеру череез ком порт компа с помощью console кабеля. Выдает такое:
http://s001.radikal.ru/i196/1311/d2/6273b1f29deb.jpg
делал все по данной инструкции
http://club.dns-shop.ru/TemaBAR/blog/%D0%92%D0%BE%D1%81%D1%81%D1%82%D0%B0%D0%BD%D0%BE%D0%B2%D0%BB%D0%B5%D0%BD%D0%B8%D0%B5-%D1%80%D0%BE%D1%83%D1%82%D0%B5%D1%80%D0%BE%D0%B2-TP-Link-%D1%87%D0%B5%D1%80%D0%B5%D0%B7-serial-%D0%B8%D0%BD%D1%82%D0%B5%D1%80%D1%84%D0%B5%D0%B9%D1%81-%D0%BD%D0%B0-%D0%BF%D1%80%D0%B8%D0%BC%D0%B5%D1%80/

Всего записей: 1 | Зарегистр. 05-11-2013 | Отправлено: 08:45 05-11-2013
westwild_007



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
HellEvil
Проверьте правильно ли установлена скорость на порту 115200
с меньшей возможны такие грабли,сам пробывал с меньшей подключаться,примерно такая картинка как у вас была

Всего записей: 224 | Зарегистр. 28-05-2008 | Отправлено: 22:04 05-11-2013
silversnomad

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Скажите пожалуйста при перепрошивке роутера TP-Link TL-WR741ND прошивкой Gargoyle  захожу веб морду ввожу пароль по умолчанию "рassword" выскакивает надпись "Invalid Password"другие пароли не подходят при попытке сменить пароль в телнете командой "passwd root" появляется строка ввода нового пароля, но нельзя ввести ни один символ работает только клавиша ентер,  соответственно перепрошится обратно не удаетсяю Есть ли какой выход с сложившейся ситуации?

Всего записей: 2 | Зарегистр. 30-10-2013 | Отправлено: 02:43 06-11-2013
KVANT0



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
silversnomad
Обычно, при вводе пароля в телнете, набираемые символы не отображаются.
Попробуйте ввести новый пароль (невзирая на то, что на дисплее ничего не меняется),
после нажатия энтер скорее всего потребуется повторно ввести пароль.

Всего записей: 138 | Зарегистр. 17-01-2010 | Отправлено: 03:00 06-11-2013
silversnomad

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
KVANT0
Спс Вам, век живи век учись )

Всего записей: 2 | Зарегистр. 30-10-2013 | Отправлено: 13:25 06-11-2013
gadabout2011

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
роутер tl-wr941nd после возврата с DD-WRT пробую подключить
 
http://i59.fastpic.ru/big/2013/1119/8e/b4b3d3b25c1cafe4b7225553beccb28e.png
 
добрался до п.4 ar7100>bootm 0xbf020000
 
http://i60.fastpic.ru/big/2013/1119/dc/3edadb068f00f4425610f76e20bf30dc.png
 
starting kernel...
и все...висит
в чем проблема может быть?
смущает
checksum bad
 
Сделал.
Ошибка в том, что заливал сразу стоковую прошивку
А DD-WRT залилась сходу.  
Роутер оживил !!!!

Всего записей: 1 | Зарегистр. 19-11-2013 | Отправлено: 23:48 19-11-2013 | Исправлено: gadabout2011, 04:20 20-11-2013
hobit26

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
ALLexusPeno
 

Цитата:
У меня есть на TD-W8951ND Ver3.0..., кому нужно могу кинуть!  

 
Если можно пришли на  hobit-style сабака майл ру

Всего записей: 6 | Зарегистр. 23-04-2009 | Отправлено: 22:42 28-11-2013
stoun



Full Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
День добрый.
 
Подскажите как восстановить W8961ND, на плате нашел только TX1 и RX1 куда подключаться?)
Модем стал кирпичем сам по себе...горит три индикатора - вкл, инет и adsl
 
Спасибо.
 
http://pikucha.ru/iclPb

Всего записей: 451 | Зарегистр. 15-10-2003 | Отправлено: 09:34 30-11-2013
IronWarrior



Advanced Member
Редактировать | Профиль | Сообщение | ICQ | Цитировать | Сообщить модератору
Попался в руки w8920g как бы работает. Но в меню нет вафли... и естественно вафля не работает...
Кто нить с такой траблой встречался? И может у кого то есть прошивка к нему?

Всего записей: 1232 | Зарегистр. 02-07-2003 | Отправлено: 02:28 07-12-2013
3DRaven



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Тем, кто пытается на TP Link-TL-WR841ND (ver 7.2) завести консоль и видит мусор, сообщаю, что там на выходе у меня в дохлом кирпиче не стандартный TTL. Потому в консоли через usb-to-rs232 кабель, виден только мусор вместо текста. Кабель я проверял осциллографом, он точно рабочий...но это паранойя, в консоли резистором замкнуть и эхо было видно. TTL на serial-e кирпича осциллограф кажет как сигнал от -1 до +1.5В и он там действительно есть, то есть кирпич что то там делает. Это значит, что для того что бы заработала консоль (я пока не проверил), надо не просто резистор подтянуть на TX (сначала попробуйте этот вариант, просто через резистор на 10К замкните TX и VCC). Так советуют импортные товарищи...может для старых версий и работало, а потом китайские братья подсуетились что бы не лез кто попало куда не надо, а версию железки не сменили для маскировки. В общем в моем кирпиче сигнал надо поднять на вольт и увеличить в два раза (что бы был стандартный TTL 0-5В). Настроение будет, проверю...надо преобразователь собрать маленький.
 
UPD: по результатам эксперимента сообщаю...ломая голову как обойтись малой кровью придумал простую штуку. Просто поменяйте менястами TX и GND. Сигнал будет 0-2.5В чего вполне хватает что бы опознать данные. Мусор исчез, консоль заработала. Никаких резисторов и проблем. Но, это только для чтения, так как передача сигнала все равно не пашет...придется делать переходник.

Всего записей: 100 | Зарегистр. 31-08-2003 | Отправлено: 06:44 11-01-2014 | Исправлено: 3DRaven, 04:33 12-01-2014
sozon32

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
http://radikal.ua/data/upload/4efc3/49112/a1c5be32bd.jpg вот у меня есть микросхема ик порта ...подскажите ведь она подойдёт?только я не пойму как со стороны ик порта соединиться к тх rx gnd и где они там .помогите понять

Всего записей: 1 | Зарегистр. 23-01-2014 | Отправлено: 02:25 23-01-2014
Pelagiad



Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Привет!  
У меня проблема с 1043ND V1.8. U-Boot 1.1.4
После настроек закрыл  коннект в админку через LAN.  Теперь не могу попасть в роутер. хард ресет не работает. 30-30-30 не работает. Роутер перезагружается при включении и выключении питания, но никак ничего не сбрасывается. решил через serial залить прошу( уже так на нём делал после неудачной DD-WRT) . Вылезла проблема все заводские проши имеют размер 8000 + 64 KiB (0x7E0200) , вместо прежних 8000 KiB (0x7C0000). Что как бы говорит, что в прошивке имеется новый ART. но команда Erase для размера 7E0200  ругается, что область вылазит за пределы допустимого. То есть теперь на сайте ТПЛИНК нет прошивок без ART-а. вопрос что теперь делать ? как теперь заливать прошивки заводские для восстановления? может кто выложит старую заводскую прошу на 1043ND с размером 0x7C0000 ? или подскажет как команду изменить Erase c более младших адресов сместить чтобы влезло или вырезать ART из новых прошивок? может нужен другой U-boot  который допустим позволит залить новый ART из новой прошивки? или может отрезать новый АRT.  залить так, а потом уже через админку залить прошивку уже с АRT-ом снова.
 
UPD
посмотрел структуру проши -  там выходит что в начале сидит загрузчик 64К (Uboot другой версии ) - а потом основной фирмварь 8000К
зато в конце 0x20200  байт залито 0xFF-ками.
Я их обрезал. Получилась проша нужного размера. Но вопрос открытый: резать в начале или в конце?
..
UPD полазил по нету.  на кит сайте нашёл что это дейтсвительно линукс +бут. отрезал бут от начала. сделал 0x7c0000
буду пробовать шить.

Всего записей: 18 | Зарегистр. 16-02-2009 | Отправлено: 13:55 25-01-2014 | Исправлено: Pelagiad, 11:32 27-01-2014
chyra

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
здравствуйте я не знаю в какой ветке писать но очень нужна помощь при прошивке TP-Link TL-WR940N
после загрузки OpenWrt роутер перешел в ребут начитавшись примеров восстановления и приобретения кабеля са-42
попытался восстановить но столкнулся с такой проблемой что после загрузки прошивки во флешь она не стартует и также в постоянном ребуте подскажите возможные признаки не загрузки во флеш

Всего записей: 1 | Зарегистр. 27-01-2014 | Отправлено: 12:34 27-01-2014 | Исправлено: chyra, 00:44 28-01-2014
Magneziy

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
в принципе все что описано на просторах интернета, я уже использовал, и многие роутеры восстановил в киеве, и тплинки 841 и 941 и 1043, а также линксисы е900 е1200 и другие
кабель для подключения к сериальному порту сделал из дата кабеля для нокии, а дальше дело техники и правильной подпайки

Всего записей: 3 | Зарегистр. 06-05-2011 | Отправлено: 13:38 29-01-2014
gelyuk

Newbie
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Всем привет,у меня роутер TP-LINK TL-WR740N Есть кабель для прошивки, все прочистил.
Подскажите где найти TX RX и KMD и какие должни бить провода соединени у  TX RX и KMD  У юсб  есть  4:белий зелений,розовий,черний  

Всего записей: 2 | Зарегистр. 07-02-2014 | Отправлено: 15:34 07-02-2014
Открыть новую тему     Написать ответ в эту тему

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26

Компьютерный форум Ru.Board » Hardware » Драйверы и прошивки BIOS » Восстановление роутера (TP-Link) через Serial

Имя:
Пароль:
Сообщение

Для вставки имени, кликните на нем.

Опции сообщенияДобавить свою подпись
Подписаться на получение ответов по e-mail
Добавить тему в личные закладки
Разрешить смайлики?
Запретить коды


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru