Перейти из форума на сайт.

НовостиФайловые архивы
ПоискАктивные темыТоп лист
ПравилаКто в on-line?
Вход Забыли пароль? Первый раз на этом сайте? Регистрация
Компьютерный форум Ru.Board » Компьютеры » Программы » Pale Moon (часть 1)

Модерирует : gyra, Maz

Maz (17-03-2018 22:15): Pale Moon (часть 2)  Версия для печати • ПодписатьсяДобавить в закладки
Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199

   

frglik23



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору


Браузер оптимизирован для современных процессоров (оптимизирована компиляция программного кода для CPU).
Pale Moon поддерживает все процессоры (CPU) начиная от седьмого поколения поддерживающих SSE2 и 3, т.е Pentium IV, Pentium-M/Celeron-M, Pentium-D/Celeron-D,AMD Opteron/Athlon64 и все современные многоядерные процессоры.
 
По данным разработчиков скорость браузера Pale Moon на 22%-25% выше Firefox, но к сожалению нет регламентированных тестов по которым можно было бы точно определить скорость.
 

(Начиная с версии 27 поддержка Windows XP x86/x64, Server 2003 и любых retail NT 5.x прекращена)
Однако, существуют пользовательские сборки под XP на основе исходников, смотрите ниже.

    Преимущества:
  • Поддержка расширений и тем Firefox
  • Оптимизированный 100% исходный код Firefox
  • Увеличение скорости выполнения скриптов и отображения страниц по сравнению с Firefox
  • Использование меньше памяти по сравнению с Firefox.
  • Расширенная поддержка DOM
  • В портативной сборке в отличие от Firefox можно одновременно запускать несколько копий программы (из разных папок).

Утилита миграции с FF на PM (Pale Moon profile migration tool): скачать
 
Ссылки:
Версия 27.x
Pale Moon 27.8.1 Eng (x86) | (x64)
Pale Moon 27.8.1 Portable Eng (x86) | (x64)

Версии для MacOS

Windows 98 | Windows XP | Пакеты локализации / Инструкция по их установке
 
Пользовательские сборки Рalemoon
Как сделать обычный Pale Moon портативным | альтернативный способ (проще)
Pale Moon commander 2.0... и перевод (папку из зипа положить в extensions)
Утилита  MozArchiver для сохранения в mht взамен неработающей на 26+ UnMHT
Disable Add-on Compatibility Checks - утилита, отменяющая проверку совместимости и позволяющая ставить запрещенные расширения на Pale Moon
Исправление невозможности запуска нескольких копий портативной версии программы (в том числе и при открытии локальных файлов)
Перечень расширений, проблемных, находящихся в работе и излечиваемых в т. ч. и Moon tester tool
MozBackup It allows you to backup and restore bookmarks, mail, contacts, history, extensions, passwords, cache etc.
Pale Moon Status Bar" можно убрать, удалив "Palemoon\extensions\statusbar@palemoon.org.xpi"

Всего записей: 1739 | Зарегистр. 24-04-2002 | Отправлено: 18:55 30-03-2011 | Исправлено: zzz528, 17:30 12-03-2018
Psm2000



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
всем привет!  
 подскажите  почему то Palemoon наотрез отказывается показывать карты Гугля . мож чо в настройках подправить ?!

Всего записей: 33 | Зарегистр. 01-08-2007 | Отправлено: 01:18 24-10-2011
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Psm2000
Может расширение какое мешает (или пользовательский скрипт). Попробуйте с отключенными дополнениями запустить и проверить (или, если есть скрипты для гугла, то их отключить). Еще в обычном Firefox можно проверить, как будет работать.
У меня в Palemoon 7.0.1 все нормально показывает
 


----------
Инструкция по выживанию для баранов, пингвинов и пр., в зимнее время

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 04:07 24-10-2011 | Исправлено: addhaloka, 04:13 24-10-2011
Psm2000



Junior Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka
 да спасибо  все перепробовал ... но заработало только тогда, когда в настройках - > вкладка "содержимое" -> убрал галку на " блокировать всплывающие окна" ... )))

Всего записей: 33 | Зарегистр. 01-08-2007 | Отправлено: 12:03 24-10-2011
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus
Чето не получается шапку поправить Пишет, незакрытые тэги
Сабж обновился до 8-й версии. Появился (впрочем, уже на 7.0.1) официальный x64 portable:
Цитата:
8.0-x64: 64-bit version of the launcher and browser for x64 Windows. Keep in mind that the same restrictions apply to this as to the desktop 64-bit version with regard to availability of media plug-ins, etc.  

Pale Moon 8.0 Installer (x32) Eng
Pale Moon 8.0 Installer (x64) Eng
Pale Moon 8.0 Zip (x32) Eng
Pale Moon 8.0 Zip (x64) Eng
Pale Moon 8.0 Portable (x32) Eng
Pale Moon 8.0 Portable (x64) Eng
 
Release notes for version 8 http://www.palemoon.org/releasenotes-ng.shtml
 
Добавлено:
Стандартное отключение несовместимости дополнений для Firefox 8:
Код:
user_pref("extensions.checkCompatibility.8.0", false);
не работает на Palemoon 8 WTF?

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 16:56 14-11-2011
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Поправил шапку.
 
addhaloka

Цитата:
Стандартное отключение несовместимости дополнений для Firefox 8:
Код: user_pref("extensions.checkCompatibility.8.0", false);  не работает на Palemoon 8    WTF?

А новое, общее для всех последующих версий?

Код:
user_pref("extensions.strictCompatibility", false);

 
Добавлено:
Zip-версии добавлять в шапку ИМХО не  стоит, они только путают людей, думающих что это портаблы.

Всего записей: 25555 | Зарегистр. 03-05-2004 | Отправлено: 17:58 14-11-2011 | Исправлено: WatsonRus, 18:00 14-11-2011
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus 17:58 14-11-2011
Цитата:
А новое?  

extensions.strictCompatibility только начиная с 10-й версии работает. Так что в сабже еще нескоро появится.

Цитата:
Zip-версии добавлять в шапку ИМХО не  стоит, они только путают людей, думающих что это портаблы.
 

Да, тоже думаю, незачем. Zip'ы удобны для ежедневно обновляемых аврор/nightly FF; или если самодельный портабл делать, а у Palemoon и так оф. портабл есть.

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 18:03 14-11-2011 | Исправлено: addhaloka, 18:11 14-11-2011
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka
18:03 14-11-2011
Цитата:
extensions.strictCompatibility только начиная с 10-й версии работает

Это как так? У меня сейчас в FF 8-ке кроме него никаких Compatibility нет, а расширения не отваливаются, только в списке расширений пишет "несовместимо бла-бла-бла". Да и в 9-ке так же.
 
Возможно, в Pale Moon-е что-то по-другому сделано...
 
Добавлено:
И помню, когда читал про эту опцию, то писали, что она уже довольно давно сделана, только по умолчанию, пока не допилят, выставлено true. А когда допилят, то вообще в списке расширений про совместимость ничего писать не будет.

Всего записей: 25555 | Зарегистр. 03-05-2004 | Отправлено: 20:12 14-11-2011 | Исправлено: WatsonRus, 20:17 14-11-2011
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus
В Palemoon 100% не работает. В 8 и 9b FF вообще этого параметра нет, в отличие от 10.0a2 и 11.0a1; в 10 и 11 видны изменения при переключении extensions.strictCompatibility из true в false; в 8 и 9b никаких изменений не происходит, даже вручную добавляя этот параметр.
Так что не знаю; у вас похоже FF какой-то волшебный
 
 
Добавлено:
Да и в логе изменений для 8-й версии чето не видно bug 693901 и bug 698653
    
 

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 20:36 14-11-2011
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka 20:36 14-11-2011
Цитата:
в 8 и 9b никаких изменений не происходит, даже вручную добавляя этот параметр.

Не происходит. Но при его добавлении вручную, расширения не отваливаются. Вам шашечки или ехать?
 
Добавлено:
А на Pale Moon я уже давно забил, хотя все еще по привычке скачиваю новые версии. На старом компе никаких различий не видно, а гемора больше. А портабл вообще запускается и выгружается хз сколько времени по сравнению с обычным Фоксом.

Всего записей: 25555 | Зарегистр. 03-05-2004 | Отправлено: 21:24 14-11-2011 | Исправлено: WatsonRus, 21:27 14-11-2011
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus (21:24 14-11-2011)
Цитата:
Не происходит. Но при его добавлении вручную, расширения не отваливаются. Вам шашечки или ехать?  
Провел сейчас тест на портативном Firefox 9b1
Подробнее...
 


----------
Инструкция по выживанию для баранов, пингвинов и пр., в зимнее время

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 23:41 14-11-2011 | Исправлено: addhaloka, 23:45 14-11-2011
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka 23:41 14-11-2011
Цитата:
если продолжаете упорно считать, что этот параметр работает в версиях до 10-й

Мне все равно, работает ли этот параметр, или нет. Важно вот это:

Цитата:
Запустил Лису - расширения работают.


Цитата:
После запуска несовместимые расширения продолжали работать.

Выходит, они как-то временно сделали, что текущий набор расширений вообще не отваливается (или это просто баг ) в любом случае.  
Добавлять/удалять я пока ничего не собираюсь, комплект расширений подобран и пока устраивает. А когда понадобится новое, глядишь к тому времени уже 10 зафиналится...
 
 
Для адептов Pale Moon куда хуже, что любые танцы с бубном не действуют на него.

Всего записей: 25555 | Зарегистр. 03-05-2004 | Отправлено: 23:50 14-11-2011 | Исправлено: WatsonRus, 23:52 14-11-2011
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
WatsonRus 23:50 14-11-2011
Цитата:
Для адептов Pale Moon куда хуже, что любые танцы с бубном не действуют на него.
Правка install.rdf выручила А без user_pref("extensions.checkCompatibility.*", false);, расширения, думаю отвалятся при обновлении на след. версию-релиз, сопсно как у меня и произошло с Palemoon.
 
Добавлено:
Решение найдено - параметр теперь такой же, как в ночнушках FF: extensions.checkCompatibility.nightly;false
Полагаю, что это правильно

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 00:08 15-11-2011 | Исправлено: addhaloka, 13:00 15-11-2011
WatsonRus



Platinum Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
addhaloka 00:08 15-11-2011
Цитата:
Полагаю, что это правильно

Правильно, что в релизе - строчка с nightly? Это, скорее, временная заплатка до допиливания фичи. Или вообще баг.
 
У меня, кстати, в профиле FF 8 тоже эта строчка имеется (еще с 7-ки), может, она и срабатывает.

Всего записей: 25555 | Зарегистр. 03-05-2004 | Отправлено: 16:50 15-11-2011 | Исправлено: WatsonRus, 19:12 15-11-2011
I_G



Advanced Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
All
Pale Moon 5,6,7,8 - В чем отличие? Я что-то не заметил

Всего записей: 854 | Зарегистр. 25-01-2008 | Отправлено: 21:10 16-11-2011 | Исправлено: I_G, 21:10 16-11-2011
caronte

BANNED
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Никому так и не удалось заставить работать вместе Pale Moon и Sticky Password?

Всего записей: 827 | Зарегистр. 29-10-2011 | Отправлено: 16:04 20-11-2011
adminzar

Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
почему не обновляют до версии 8.0.1 ??!!!

Всего записей: 330 | Зарегистр. 02-02-2007 | Отправлено: 14:04 25-11-2011
dev2null



BANNED
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
adminzar (14:04 25-11-2011)
Цитата:
почему не обновляют до версии 8.0.1 ??!!!

Имхо, незачем, по двум причинам:
1. обновление FF до 8.0.1 относится к багу в MacOS, а Palemoon под мак нет.
2. второе исправление в FF 8.0.1 касается расширения Roboform, но его добавили в чёрный список, который у всех автоматически обновляется (раз в сутки, по-моему) независимо от версии Firefox.
 

Всего записей: 574 | Зарегистр. 23-10-2011 | Отправлено: 00:42 26-11-2011
adminzar

Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
а сейчас чего не обновляют??

Всего записей: 330 | Зарегистр. 02-02-2007 | Отправлено: 22:42 29-12-2011
addhaloka



Gold Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
adminzar 22:42 29-12-2011
Цитата:
а сейчас чего не обновляют??

Pale Moon 9.0 выпустят в январе

Всего записей: 7432 | Зарегистр. 13-11-2010 | Отправлено: 23:27 29-12-2011
neoaeon



Member
Редактировать | Профиль | Сообщение | Цитировать | Сообщить модератору
Pale Moon 9.0.1 has been released, which sees some further improvements in script and network handling, among other things.
http://www.palemoon.org/download-ng.shtml

Всего записей: 331 | Зарегистр. 21-02-2006 | Отправлено: 15:23 09-01-2012
   

Страницы: 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88 89 90 91 92 93 94 95 96 97 98 99 100 101 102 103 104 105 106 107 108 109 110 111 112 113 114 115 116 117 118 119 120 121 122 123 124 125 126 127 128 129 130 131 132 133 134 135 136 137 138 139 140 141 142 143 144 145 146 147 148 149 150 151 152 153 154 155 156 157 158 159 160 161 162 163 164 165 166 167 168 169 170 171 172 173 174 175 176 177 178 179 180 181 182 183 184 185 186 187 188 189 190 191 192 193 194 195 196 197 198 199

Компьютерный форум Ru.Board » Компьютеры » Программы » Pale Moon (часть 1)
Maz (17-03-2018 22:15): Pale Moon (часть 2)


Реклама на форуме Ru.Board.

Powered by Ikonboard "v2.1.7b" © 2000 Ikonboard.com
Modified by Ru.Board
© Ru.Board 2000-2018

BitCoin: 1NGG1chHtUvrtEqjeerQCKDMUi6S6CG4iC

Рейтинг.ru